Virus Problems & Hardware detection error

  diode 17:14 26 Dec 2005
Locked

My son is running a PC with XP pro. I ran AVG antivirus and it has detected 3 viruses in a zip file (count.jar-43c66fb6-14c3949a.zip) called BlackBox.class, Verifier.class, and Beyond.class. I tried to follow through on the AVG suggested removal which says if you haven't got Java plug-ins installed you can delete the appropriate file. When I do this it appears to prevent access to the internet. Any advice much appreciated.
A bit of further info, on boot up it keeps generating a message that New hardware relating to an Ipod has been found, even though no such item (we don't have one) or infact anything is plugged into any of the ports.
I am not sure if the Online gaming that appears to have installed itself in favourites(and cannot be deleted is any connection, it also appears to have installed a browser bar at the bottom of the screen which also I don't appear to be able to remove.

  VoG II 17:21 26 Dec 2005

Try downloading Winsock fix click here then remove the file, then run Winsock fix.

Also scan with Ewido click here

  diode 18:46 26 Dec 2005

Thanks for your input VoG, folloed your instructions and that worked beautifully to eradicate the virus(es). I must say I was very impressed with Ewido it picked up a further 33 items that Adaware and Spybot had missed.
I think the problem I am having on Boot up. "Found new hardware" then launching the Wizard to connect to "Ipod service" then "A problem occurred during hardware installation and might not work properly" (even though nothing is connected) is not associated with the virus as it is still appearing on boot up.
Also the alien browser is still appearing and there doesn't seem anyway to find out how to remove it. Any further ideas from anyone would be much appreciated.
Much obliged to VoG for curing the virus problem.

  VoG II 19:22 26 Dec 2005

Try running MS Antispyware click here

  diode 21:09 26 Dec 2005

We now seem to have cured the alien browser. My son now informs me that he tried to set up a partnership with a PDA he thought it said to have the PDA attatched initially, however he realises that it should have been diconnected. Looking at My Computer a Mobile device is showing, although nothing is connected,and none of the USB ports will recognise anything that is plugged into them.

  VoG II 21:14 26 Dec 2005

Have a look in Start, Control Panel, Add or Remove programs. Have a look for the PDA program that your son tried to install. If you can find it (and you are sure it is the right program) then left click it and choose 'Remove'.

  diode 21:25 26 Dec 2005

Thanks VoG, I looked for that earlier, just looked at device manager and see that there is an Ipod service that I have uninstalled I think we might have a solution. Will report back if it is all resolved.

  diode 23:23 26 Dec 2005

I will put this down as resolved although the alien browser has reappeared, at least my son is now up and running again,the virus is solved and USB problem appears to be solved. Thanks for your help it is much appreciated.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?