Video adapters not recognised/installed

  greybeard 22:39 26 Aug 2009

I'm rebuilding a desktop pc to use just for off-line graphics and printing.
Win98se on a Gigabyte GA-5AX/AMD [email protected]/256Mbmemory.
I know the spec is slow and old, but it's fit for purpose.

I have two hdds - a 1gb Quantum hdd that contains a working copy of 98se, but little else, and a 6.4gb Samsung hdd that contains the same os copy, and about 4gb of graphics software and data files that are needed.

The 6.4 ran perfectly well prior to my removing it from a older system which is now running Ubuntu/emc2 with a new hdd.

If I instal the 1gb hdd, it will run the monitor perfectly well at the resolution I require, with any of the three pci video boards I have at my disposal.(The motherboard bios has only PCI or AGP as options, and no onboard video).

However, if I install the 6.4gb hdd, I can only use a vga driver, running 16 colours.
(Running in safe mode gives me 256 !)
I have tried many times installing each of the video boards in turn, but however I try, the end result is the same - none of them are recognised, nor installed.
Otherwise, it seems to behave normally.

I have Everest installed as a useful system tool, and it recognises the board each time.
The splash screen at boot up also correctly indicates what video board is present, but the Control board/settings/system never indicates the video adapter as being installed.

Solving the problem of installing the video boards would be the tidiest solution, and I only offer the two hdds as proof that there is nothing wrong with the mobo, nor, possibly, my ability to install a video board.

I've considered, and tried, running both as master/slave, but that produces even more problems.

Any help gratefully received.


  greybeard 09:35 27 Aug 2009

Add New hardware/choose from list/cirrus/cirrus pci5436.
Asked to insert win98se cdrom "Cannot find Supervga.drv" and then Browse to get to drivers/display/cirrus, but only 5436agp or 5436pci shown, so I chose 5436pci.
None of the files it then asked for after skipping each in turn, could be found.

No idea what to try next.

  greybeard 09:59 27 Aug 2009

...... This time at the insert win98 cdrom request, I sent it to d:/win98 and it extracted something, but then didn't ask me to reboot, and nothing changed.
I did it anyway, but no progress - it's still only got the Standard VGA adapter installed.

  Jim_F 10:02 27 Aug 2009

It sounds like previous installs on the 6.4gb are blocking installation of the correct drivers - basically windows (thinks) it knows best.

You can try searching for and deleting GFX installs in the\inf directory - these will appear as OEMxx.inf files which you can open in notepad to check although a fresh install of win98 may be better.

I remember than win9x was quite picky on GFX card upgrades - the standard proceure was to install the vanilla msoft vga driver and then upgrade.

A reinstall shouldn't touch your data files unless you format but I would try and back up the files - its often easier to just put one ide drive on each cable but I'm wondering if the problem is 2 boot drives rather than master/slave.

  greybeard 10:23 27 Aug 2009

Thanks Jim.
I went back and tried having two hdds installed, but only then did I discover problems if I transfered any data from the 6.4 to the 1gb.
It completely froze if I tried to shut down, so my idea of transferring data fro mone drive to the other might not have worked either, so I abandoned that aproach, at least for the time being.
Re the gfx installs, I'll have a little explore and come back with info, and for advice, as necessary ;)

  Jim_F 10:27 27 Aug 2009

In my third para I meant to say Uninstall any previous cards and drivers and install the standard vga driver prior to a new driver install.

(Otherwise windows had a habit of using what was already there).

I seem to recall that it was necessary to select the windows vga driver and reboot - I'm guessing that windows would install after a failed driver install but that this blocked further driver installs.

  Jim_F 10:29 27 Aug 2009

Sorry - hadn't seen your last response - good luck !

  greybeard 11:57 27 Aug 2009

I had a look in the windows/inf files and found two references in the inf/other file to the two other video adapters that I had recently tried, Sis and S3trio.
(I moved these to a new file for safe keeping)
The other references to cirrus and s3 showed MS as provider, so I left those where they were, as I assumed these referred to Windows own instal method, if you see what I mean.

I then tried installing the cirrus board, and though this showed a slightly different window opening(Windows building a driver database), again it didn't ask me to reboot at the end of the process, and hasn't changed anything.

Before posting this, I've just had another look and found a reference to an ATI display driver.
However, the Add/remove prog doesn't let me remove it -"Error initialising".
The inf files refer to a tv tuner board, but as I've no idea where this has come from, I'm happy to delete it.
Do I do this by removing the references in the Windows/inf folders, as before ?

  greybeard 18:09 28 Aug 2009

I've now got a cirrus video card recognised/installed, and though the Display properties/settings gives me the appropriate choice, choosing a different setting has no effect at all !
I've now gone to control panel/settings/display adapter/cirrus/properties/resources where it reports " not match any known config...set manually"

i/o range 03B0 - 03BB, 03C0 - 03DF
mem range 000A0000 - 000AFFFF, 000B8000 - 000BFFFF

Can anyone offer advice on what I should set these to ?
I understand what's involved, but not what is appropriate.

  greybeard 22:15 28 Aug 2009

Not 100% certain how I managed it, having tried quite a few things, but the last was to run scandisk.
Te first time I ran a "Thorough check" and that froze, so I restarted using the "Standard check",and that found no errors.
I ran it a third time with a "Thorough Check", but only on the system folders, and checked the "Fix errors".
It ran OK, and reported no errors.
Out of curiosity, I tried the Display/settings again, and changed the setting to a higher resolution, and apply without restarting.
This time it finally took notice and gave me the setting I wanted.
I've now rebooted, and tried changing it again, and it still works, so fingers crossed, the problem is resolved.

  Jim_F 10:19 29 Aug 2009

The IO problem is usually due to the bios not providing resources that windows recognises as standard - either because another device is parked there or the bios is not set to give control to a PNP OS. The answer is either to free up resources in the bios or select any available resources in Windows - if its working then I'd leave it be.

Getting rid of some drivers (like ATI) can be difficult if some of the install package is missing - Driversweeper click here will do the job but requires .net to be installed.

Glad you got there in the end !

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?