Very, very slow startup and 'loss' of BT home hub

  PCA reader 09:59 22 Oct 2007

Running on XP Pro SP2, Athlon 1900+, BT Home hub (Thomson NDIS device)...... I'm experiencing very, very slow startups, typically >90secs, to get to the windows splash screen. Also, the windows shut down screen lasts forever, requiring a power off to get out.
Starting in Safe mode is fine and the only 'issue' I can see is in Device Manager. My BT Home hub (Thomson NDIS Device USB attached) is shown as disabled. the detail shows 'no driver loaded' although the Driver details shows the correct s/w. Enabling the device fails giving a no driver loaded msg. I've tried reinstalling the home hub but got same result.
The only other network device shown is '1394' which is disabled with code 22.
I suspect a Network Services issue of some sort ie Windows is taking ages to look for something during boot up/turn off.
Any ideas much appreciated.

  RobCharles1981 12:20 22 Oct 2007

When was the last time u done the following?

1. Check for startup items in windows msconfig, if so take out some programs you do not need, this will speed up the startup process.

2. When did you last clean the inside of your case? Use an Aircan to get rid of the dust from the fans.

3. When did you last do some housekeeping?
What Antivirus and Spyware do you have on your computer? Do you have ccleaner installed?

come back to us.


  PCA reader 12:54 22 Oct 2007

Thanks Rob.
I cleaned or at least gently vacuumed the inside of the case when I reinstalled XP about 1 month ago.
Housekeeping is up to date - I regularly run Reg Mechanic and keep an eye on disk space although I'm only using ca 30% of 250gb of my C drive. Large files, photos, are on a USB connected 250gb Freecom drive.

I'm running Norton 360 and did a full scan couple of days ago with no problems shown.

I'll run msconfig in safe mode and disable all startup progs not necessary e.g BT help advisor, Winpatrol etc.


  RobCharles1981 13:23 22 Oct 2007

"I'm running Norton 360 and did a full scan couple of days ago with no problems shown"

There is your problem, the dreaded Norton that's what is making your rig so slow and theres no need to pay for software where you can get the freebies.

click here

Download and run that, and use ccleaner click here to get rid off all left overs.

Get this free software from click here:

Antivirus Software:
Avast Antivirus


Spyware Terminator
Super Antispyware
AVG Antispyware
Spyware Blaster (As a Blocker)

Update them all, and run some scans with them.

click here

Get Iobit Advanced Windows Care as well.

Your Rig should be flying.

  PCA reader 13:40 22 Oct 2007

I have heard about Norton causing slowness but it has been fine for a couple of months now and far better than Norton 2007.
I'll disable it at startup and keep off the net to see if that makes a difference to startup times.
Don't see it will help the Network adaptor disabled issue though.

All of course will have to wait until I'm back at home this evening and I'll post an update later.

  brundle 13:53 22 Oct 2007

Norton products are more streamlined these days, however it won't be causing your 90 second delay anyway. Go to start menu/control panel/folder options, click View, untick the first box "Automatically search..." etc etc.

Disable boot screen and see if the startup process is hanging at a particular process; Start menu/run, type msconfig, click the Boot.ini tab, select the entry starting `multi(0)disk(0)` and tick the /SOS /NOGUI boxes. Reboot.

  brundle 14:19 22 Oct 2007

Also, I would suggest connecting to your Hub via Ethernet if you have a suitable input on your PC, rather than USB.

  PCA reader 16:06 22 Oct 2007

Thanks Brundle. I shall try these.

  ambra4 05:12 23 Oct 2007

Go this site and go down to Home Hub FAQ

click here

  PCA reader 10:24 23 Oct 2007

Ok, last night I removed all bar essential startup items. These were related to the BT desktop help, soft phone etc, etc. I then rebooted without the hub connected.
All was pretty swift with no 'hanging' type problems.
I then powered off the hub, left it for 10 mins and repowered on. I found this tip in the useful link Ambra4 posted above.
Reconnected hub and all was fine. Rebooted and still all was OK, hub showing as connected at 12mbs and the 1394 connection also active at 400mbs.
So I think problem was down to either the BT startup progs and/or the hub being screwed.
Of course in hindsight if I had made one change a time and rebooted I would have more likely been able to pin down the precise problem.
However, it works now so I'll leave well alone!!
Many thanks guys for the tips.

One question though.....Googling for '1394 connection' tells me that this is for Firewire but as I do not have Firewire capability is it ok to leave as is or should I disable it?

Thanks again

  ambra4 12:49 23 Oct 2007

Just disable it

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

The secrets of creating gory VFX

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache