Vaio PCG 4K1M does not switch on or charge

  rob_gould 11:45 26 Nov 2009

Hi All,

Bit of a sticky situation here that I'd appreciate some advice on :

The background :

My dad gave me his Vaio PCG 4K1M laptop because the screen needed replacing.

I (idiotically) took the main body of the laptop to bits withouth realising you didn't need to do that to replace the screen.

I put the laptop back together (with the faulty screen) and everything still worked perfectly. I then worked out how to remove the screen itself, and did so.

I spent £220 on a new screen, and about a week later put it in (this time without opening up the main body of the laptop).

Now, the laptop does not start when I press the power button, and the LED does not light to indicate that the battery is charging when plugged in.

I know the PSU is OK as it reads 16.08V on my multimeter.

So - I'm presuming this must be a lose connection somewhere, as it 'broke' when it was sitting doing nothing for a week, untouched.

Any ideas where to start looking to solve this fault - laptop shows no indication of receiving power when PSU is plugged in?

Many thanks in advance,


  Technotiger 12:02 26 Nov 2009

First thing to check is All the Power items and connections, including the fuse in the plug!!

  rob_gould 12:05 26 Nov 2009

I know the PSU is OK as it reads 16.08V on my multimeter.

  Technotiger 12:50 26 Nov 2009

But I did not mean just the PSU, check All Power cables/connections/fuses etc, starting with the simplest - the fuse in the Mains plug!

  rob_gould 13:14 26 Nov 2009


Sorry, perhaps I am not being clear.

I plugged the PSU for the laptopinto the mains, the LED on the PSU lit, I measured 16V from the connector on the end of the PSU that plugs into the laptop, but when I plug this connector into the laptop nothing happens. No charging light, laptop does not switch on.

The problem is with the laptop, not with the PSU

  Technotiger 13:28 26 Nov 2009

Laptop power connections cause loads of problems - probably suggesting what you already know, but check the lead from PSU to lappie, check the lappie power socket, and also its connection at the mobo - could be a simple dry joint. Have a very close look for any signs of burning/melting on mobo, such signs could be very small and hard to see. Check any fuses in the lappie itself.

  Technotiger 13:30 26 Nov 2009

Could also of course, be a dodgy On/off switch on the lappie.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?