USB2 Bandwidth problems

  rustysutton 20:16 06 Apr 2006

Wondering if someone can help. The only thing I have plugged in my USB is a wireless keyboard/mouse receiver and a Speedtouch 330 USB ADSL modem.

My problem is that when I plug in my Bluetooth USB dongle I get an error message stating that I have exceeded the bandwidth for the USB controller.

I was under the impression that the bandwidth threshold for USB2 was 480 MBPS. Surely my wireless receiver and modem cant be using all of that - can they?

I have checked in Device Manager and I have a Standard Enhanced PCI to USB Host Controller showing and a Standard OpenHCD USB Host Controller. Underneath this there are also entries for: USB Composite Device, USB Mass Storage Device (my memory card reader I presume?), USB Root Hub (x2) but all springing from the same Universal Serial Bus Controller.

The only way I have found to get my Bluetooth device to work is to leave it plugged in when I switch on my PC. However this then restricts my Broadband to a 4 meg connection instead of 8.

Any words of wisdom would be greatly appreciated.


  skidzy 21:04 06 Apr 2006

Not sure if this will help,maybe worth a try..
click here

  phono 21:40 06 Apr 2006

If you install a USB 2.0 PCI card you could plug some of your devices into it without exceeding the bandwidth.

Also try click here for an excellent site on all things USB.

  rustysutton 22:37 06 Apr 2006

Thanks for advice. I was going to try a PCI card but was still curious as to why all the bandwidth was being eaten up by a couple of devices.

  rustysutton 22:50 06 Apr 2006

Have just looked at the 2 USB controllers again and everything I plug in seems to try and automatically feed from the standard controller and not the enhanced one. Standard controller is showing that it has my modem attached which is using 75% of the bandwidth and 23% allocated to system resources. The enhanced one has nothing except for 10% allocated to System Resources.

Anyone got any further ideas?

  phono 23:15 06 Apr 2006

Maybe all your devices are USB 1.1, I don't know if that should cause this problem though.

In my own case I have a mobo which has 6 onboard USB ports, four at the rear and two on the front of the case via a mobo header, I also have a 4 external + 1 internal ports USB 2.0 PCI card fitted and I have never exceeded the bandwidth.

Have you tried uninstalling and reinstalling all USB devices in device manager? There is a section on the USBMAN website, see the link in my previous post, which explains how to go about this, it sometimes cures USB problems.

  Stuartli 00:14 07 Apr 2006

I've got eight USB ports (with a four port 1.1 USB powered hub running off one of these) and have still to find the limit.

  rustysutton 15:04 07 Apr 2006

Thanks for advice I've tried all the things suggested so am still at a loss what to do. it just seems really strange to me.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

This is what design agencies will look like in 2032

How to update iOS on iPhone or iPad

WhatsApp : comment lire vos messages sans que l’expéditeur le sache