USB storage device problems

  Stephanie 20:56 05 Feb 2011
Locked

I have a problem with my USB ports not recognising various hard drives, an iphone and a card reader which all worked perfectly up until yesterday. When I connect any of these items I get a pop-up saying "One of the USB devices attached to this computer has malfunctioned, and Windows does not recognise it." This happens with any USB port and any cable and with all my USB devices with storage. My keyboard, mouse and printer work without problem in any of the ports.

Sometimes, with a few reboots I can get a device working for a while, but then it disappears and I get the above message.

In device manager, the offending port shows up with a yellow exclamation mark and the properties state "Windows has stopped this device because it has reported problems. (Code 43) I've tried uninstalling and letting Windows reinstall for only temporary cure.

I am running Windows 7 Home Premium 32bit and have made no hardware or software changes recently apart from installing the latest version of itunes. I have run a virus and malware scan which found nothing.
I did a system restore back to the weekend, as I had installed some windows updates but the problem persists.


I am at my wit's end as I can't work out whether this is a hardware or Windows problem. Any help would be much appreciated.

  Fruit Bat /\0/\ 21:23 05 Feb 2011

Ghost device conflicts are the mostly cause especially for devices that are connected and disconnected regularly i.e. pen drives, external drives, mp3 devices and phones.

Remove all USB devices

click here

Download and run

Uninstall ALL devices that are shown as not connected.

Reboot the machine.

Plug in your USB device and windows should then find new hardware and reinstall the drivers for the device.

  Stephanie 19:29 06 Feb 2011

Let me list what I have done so far to try to cure this problem.
1. Uninstall items with yellow marks from Device Manager and reboot.
2. Uninstall all USB Universal Host Controllers from Device Manager and reboot.
3. As 1. and physically unplug PC then reboot.
4. Run USBDeview and delete every entry and reboot.
5. Try updating drivers for USB devices without success.
6. Use different cables to connect and different ports.

None of these has cured the problem with USB storage devices. My mouse, keyboard and printer have worked throughout in any port.

I can think of nothing further to do and wonder if re-installing Windows would help as a last resort. My heart sinks at the thought but unless I can get my external hard drives, iphone and ipad communicating with my PC it is seriously useless.

Many thanks to all of you for your suggestions. I'm only sorry I can't report any success.

  robin_x 20:00 06 Feb 2011

This post prompted me yesterday to run USB Deview.

It would accept uninstall option, but not actually do it. ie the item did not disappear.
No errors or warnings.

I downloaded latest USB Deview (1.86) and also ran it as Administrator. That worked. I guess the latter.

Also saw there are hidden things in the app.
Click Options and check unchecked items.

Careful not to uninstall mouse and keyboard.
After all this I must admit my Flash cards are still hit and miss on my laptop/cheap hub.

Apart from that I have no idea what could be the problem. Sorry.

  Stephanie 20:38 06 Feb 2011

I'm connecting directly to USB ports. Also I did uninstall everything with USB Deview including hidden items. I actually managed to disable my mouse and keyboard so had to shut down using the tower on/off switch which is, luckily, set to do a proper shut down. On restart, my mouse, keyboard and printer reinstalled correctly and there were briefly no yellow exclamation marks. However, when I connected one of my hard drives, the driver failed to install. I repeated the whole process with USBDeview etc. and tried with another drive and the same result. I'm tearing my hair out.

  Fruit Bat /\0/\ 21:18 06 Feb 2011

Surprised deview hasn't done the job.

Have you tried powering the devices through a powered HUB?

  Stephanie 22:57 06 Feb 2011

I haven't got a powered hub, unfortunately. I should say that whatever problems Windows has seeing my drives, the ones powered through the USB port always show that they are charging.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

AMD Ryzen news - release date, UK price, features and specifications

The 12 best apps for drawing and painting on your iPad

Mac power user tips and hidden tricks

Comment faire des captures d’écran sous Windows 10 ?