USB Printer problem

  canute44 21:03 28 Feb 2004

Today after several months of faultless printing my Epson Stylus Photo 1290 has gone on the blink. When I try to print anything, it gets a little way into the printing and then a communication error occurs. The printer stops mid print and blinks its power light at me. A short time later an error message from windows (OS Win Me) tells me that it is unable to access EPUSB1 port. The ink levels seem fine, the paper has not jammed, all connections seem firm, all other USB devices work OK including my laser printer. Nothing has been changed since I used the printer yesterday. I have rebooted warm and cold. Surely if the printer has started printing, connection must have been made. The only thing I can think of is memory full which should clear if I switch off - tried this without success. Any ideas?

  Gongoozler 21:55 28 Feb 2004

Hi canute44, not that this is much help, but this symptom is exactly what I used to get with my old motherboard that had a known usb problem. I think it was caused by the computer sending a batch of data, but not responding to a request for more data. I cured this with a new motherboard. Hopefully this will bump you back to the top and attract a more useful response.

  canute44 22:00 28 Feb 2004

Gongoozler: I don't know whether to say thanks for that or not! I have recently had to have a new hard disk. Expenditure recently has been high in all directions so please let it not be the mobo!!

  Gongoozler 22:07 28 Feb 2004

If your motherboard works well with all the other usb devices, then I think it's probably ok. You should be able to confirm this by swapping some of the connectors around.

  JIM 22:14 28 Feb 2004

Try a system restore back a day or so, incase of corruption.You could check the printer out and setup via Parallel cable.

  canute44 22:14 28 Feb 2004

That's the only thing that I can think of that I haven't checked but as everything is over, under or behind something else I'll try a bit of swapping in the morning. As I said in my original posting, I have waggled and poked and prodded everything I could get at easily but it made no difference. There was one thing that I forgot to put in and that was that my PC accused me of disconnecting a USB item without hitting the unplug icon first. I had nothing wrong, 'onest guv. I had not disconnected anything. This might indicate a poor contact. I'll give everything another going over in the morning.

  canute44 22:17 28 Feb 2004

JIM: I'll also do a system restore. From another Jim!

  Gongoozler 22:19 28 Feb 2004

Sounds like it could be a dodgy cable. Try a cable swap and see if it makes any difference.

  canute44 22:22 28 Feb 2004

Gongoozler: Why should a cable go dodgy overnight? If it moved about I could understand but the thing just hangs there! Anyway, that's certainly on the cards for try out. Thanks.

  canute44 22:50 28 Feb 2004

Bl...y computers! I have just tried doing a system restore and it says that it can't. Also, printer has just complete 3 jobs from 3 different programs. Would you believe it? Classic intermittent fault replaced by another! And so to bed! Grrrrr!

  canute44 16:55 29 Feb 2004

Since starting up everything this morning all has seemed to be fine and daughter has printed off her homework on the Epson without mishap. So I shall leave all fiddling with connections etc until the problem recurs. I shall tick as resolved and restart the thread if I have further problems. Very many thanks to you all for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?