USB - power on but no connection?

  ANDY-212408 20:00 08 Mar 2007

I have just had a mate on the phone saying that his usb ports are not working. He has the usual two at the front and two at the back. I said to him to check that they were connected by looking inside - to which he replied they must be cause his son is charging his mp3 playing in one. I asked him to check drivers and the system information is saying that the device is working correctly - he has already tried a system restore, which didn't work.

Has anybody come across this before or are there any ideas as to what may have gone wrong?


  Iron Maiden 20:11 08 Mar 2007

I would think that if his son is charging his mp3 player in one that he is draining all the usb power
take the player out a charge it on the mains then see if they work ok. If they are ok he needs a more powerful power supply if they still want to charge things on the pc & use the other ports

  ANDY-212408 20:25 08 Mar 2007

Thanks for the prompt reply.
Although a good shout it is still not working when items are not being charged via the usb. I used that as an example that power is present but no actual connection.
Thanks again

  Fruit Bat /\0/\ 20:27 08 Mar 2007

the device is working correctly

unfortunately device manager does not always tell the truth.

Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  ANDY-212408 21:10 08 Mar 2007

He has just tried the reinstall but unfortunately it has not solved the problem. Any other ideas folks?

  Fruit Bat /\0/\ 21:16 08 Mar 2007

USB equip not recognised
Try switching the computer off and at the wall. Then hold the start switch in for 30 seconds or more, and then re boot.

  ANDY-212408 21:49 08 Mar 2007

but no joy. I think it might be a hardware fault with his USB controller. Because he has power would pluging in a usb adapter solve the issue if the main usb controller is faulty or does the usb controller need to fully working to run an adapter?

  phono 21:54 08 Mar 2007

If the USB controller definitely is faulty there would be no point in plugging a hub into it as it wont work.

The best solution would be a PCI USB controller card, providing of course there is a free PCI slot on the motherboard.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?