** USB ports not working!! Please help!!!!!! **

  Hobbers79 20:00 20 Oct 2006
Locked

Hi,

I have owned a Mesh computer for about 3 months, and all was going well until 2 weeks ago. I was using my Epson DX4850 to print some pages off Ebay and had printed a number of pages, when the computer seemed to freeze and the printer started printing a whole load of code. This continued through many sheets of paper and the cancel button wouldn't stop it, so I turned the printer off and rebooted the computer. I had only had the printer about 3 weeks. However, when the system loaded up again it would not recognise the printer, suggesting that it is not connected, even though the printer cable is correctly connected. Worse still, the USB ports would not accept any other devices, like my digital camera! When plugging that in, a drive letter is created but when I click on the drive letter, it incorrectly shows the drive as being empty. The computer also won't recognise any memory cards that are put in to it's in-built card reader!!

When looking in Device Manager, with the printer connected, there is an exclamation mark next to 'USB Mass Storage Device'. The device status for this reads: "This device cannot start. (Code 10)". There is also an 'unknown device' listed under the USB tree.

I have uninstalled all the printer software/drivers, and then installed them again from scratch. However, it won't install the printer driver now as it still says it is not connected - even though the cable is in the right place!

When the camera is plugged in, exclamation marks also appear in the device manager, but these are not always in the same place and come and go.

Mesh first of all advised a System Restore back to before the errors started, but that didn't fix the problem. They then suggested that it could be caused by a Windows Security Update and that many other people were suffering similar problems! Their suggestion was therefore to reinstall Windows!! I'm not to keen on this as it will wipe all my files and I have no guarantees it will solve the problem!!

Has anyone else come across this, or more importantly, does anyone know how to fix the problem??? I'm pulling my hair out here!!!!

Thanks!! :-)

  woodchip 20:25 20 Oct 2006

It looks like the Printer is faulty, the Motherboard USB fuse as blown (not replaceable). You need to contact Mesh

  woodchip 20:26 20 Oct 2006

PS you may have overloaded the USB ports and Auto protection as not worked

  Jak_1 20:27 20 Oct 2006

Delete all usb devices in device manager then re-boot, plug in each usb device and let windows find new hardware. This should solve the problem.

  Hobbers79 20:36 20 Oct 2006

Thanks for your help.

Firstly, Mesh seem to think that it's not the hardware and that it's Windows that is causing the problem. Although, the Mesh helpdesk weren't the most helpful or intelligent people I've ever met! Could it really be something that serious??

Secondly, I just tried deleting the devices, rebooted and it started loading the USB drives again. However, an error message then appeared:
"One of the USB devices attached to this computer has malfunctioned, and Windows does not recognize it."

It then shows the USB tree, with 8 ports. But the 6th one down says "Unknown Device" in bold.
Under Recommendations it says:
"Try reconnecting the device. If Windows does not recognize the it, replace the device."

When looking at the properties for the 'unknown device', it says:
"No drivers are installed for this device"

Nothing is attached to this port though. All the USB ports are empty, but I'm still getting these problems.

Any ideas what's going on???

  woodchip 20:42 20 Oct 2006

You should remove all Hardware from USB ports before uninstalling USB from Device Manager then plug USB in after all USB have reset. Try it again

  woodchip 20:43 20 Oct 2006

PS you could try Restore to old date

  Hobbers79 21:43 20 Oct 2006

Thanks for the advice. I did remove all hardware from the ports when I did that. All ports were empty. I then deleted all the USB devices in Device Manager, leaving just the host controllers.

I also tried a system reset back to before the problem, but that didn't help.

Any other suggestions??
:-(

  woodchip 21:45 20 Oct 2006

Just as I said in my first post

  Fruit Bat /\0/\ 21:57 20 Oct 2006

Delete the controllers!

Uninstall EVERYTHING under the heading USB in device manager.
Reboot the PC let XP find new hardware and reinstall the ports and anything attached to them.

  Totally-braindead 22:02 20 Oct 2006

If the above advice doesn't work then personally I think its more than likely the motherboard USB thats failed as woodchip has suggested. The only other suggestion I have is try a repair of windows rather than a full format and restore. If you do this all your files and programs should still be there.
Incidently I presume the computer has either a cd or a dvd writer and strongly recommend backing up your files before you do anything else.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?