USB ports not working

  deneka 22:27 02 Aug 2009
Locked

I am running on windows Vista, 32bit. All USB ports are not working (front & back).
yellow exclamation mark showing in device manager for USB ports. Power is going to the ports but no device is recognised. Driver updates say that it is up to date. Windows update will only get to stage 2 of 4. Any ideas/suggestions of what we could try next please?

  GaT7 22:29 02 Aug 2009

Did this happen all of a sudden?

Anyway try these for a start click here? G

  deneka 22:34 02 Aug 2009

Yes just looking at that. Yes happened all of a sudden, was working 11/07 and now it won't! camera recognises it is plugged into USB but USB does'nt recognise that the camera is plugged in. Will not recognise any other devices either, e.g printer, memory stick

  Sea Urchin 22:42 02 Aug 2009

The Fix-It button on Crossbow7's link worked for my neighbour a couple of weeks ago.

  deneka 22:51 02 Aug 2009

Just tried that. Get the message 'the microsoft fix it does no apply to your operating system or application version'

  Halmer 15:36 03 Aug 2009

through device manager and then rebooting?

  Kevsta1981 15:58 04 Aug 2009

Hello

I am a friend of deneka's and i was down her house on sunday trying to help with this problem.
Have not tried uninstalling the ports themselves only the drivers and then re-installing.
So, should i right click and try uninstalling the host controllers or all of them?
And if i did windows would detect this on reboot?
Could it maybe just be a missing .dll file?

  Fruit Bat /\0/\ 16:33 04 Aug 2009

should i right click and try uninstalling the host controllers or all of them?

yes but careful if you have a USB mouse /keyboard

And if i did windows would detect this on reboot?

yes the drivers will be reinstalled on reboot


Could it maybe just be a missing .dll file?

no, probably a corrupt driver.

  Kevsta1981 08:55 07 Aug 2009

Problem fixed

Turned out to be an issue with Kaspersky.
Tried all of the recomended methods suggested with no joy but as soon as we renewed Kaspersky, drivers started installing and USB's were fine. *shrug*
This is why i dont get on with anti-virus's. Too overprotective sometimes.

Thanks for the help anyway guys

  Sea Urchin 12:38 07 Aug 2009

.....or have you changed your name from deneka to Kevsta1981?

  GaT7 12:43 07 Aug 2009

"And who are you?"

"I am a friend of deneka's..." - see post of Tue, [email protected]:58

G

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?