USB port access problem

  rekcoc 13:27 21 Mar 2003

I have Aries Perfecta Pro with Win. XP. I have tried operating a Microsoft Sidewinder joystick via the front USB, but it will not recognise the port. It works OK in a rear socket. Is it possible that the front port is switched off. If so how can I check its status and switch it on?

  Tj_El 13:32 21 Mar 2003

does the fron USB port work with any other USB device you have?

  pj123 23:41 21 Mar 2003

It maybe the cables inside the case are not connected to the motherboard. It may be that the motherboard does not support front USB ports. You would need to open the case and check.

  woodchip 23:46 21 Mar 2003

Cannot see Watford missing a point like that

  rekcoc 15:06 22 Mar 2003

Thanks for suggestions. New at this game!
Haven't tried other device yet. Must do. Managed to access device controller. 8 entries for USB's.
1-4 Open host controller
5-8 Root hubs.
All shown as working correctly. Doesn't mean much to an idiot!! But presumably must all be connected.
You got Aries woodchip? Very pleased with mine.Will try 'all in one' in front.

  woodchip 15:10 22 Mar 2003

No but I have bought from them in the past

  woodchip 15:12 22 Mar 2003

PS you could remove all USB in Device Manager and restart your computer to let it rediscover them

  rekcoc 20:14 22 Mar 2003

Woodchip. Thanks. I may try out a webcam to-morrow which I think is USB. Save me taking pc out of cupboard to disconnect all in one. Keep you posted.

  ams4127 20:56 22 Mar 2003

Go back to the Device again and double click each USB Root Hub in turn. Click on Power Management and make sure that the box which allows Windows to turn power off is unticked.

  rekcoc 21:44 24 Mar 2003

Ams 4127. Sorry wasn't ignoring you--been out of touch. Done what you suggested. Have to wait to re-test port. Come back to you.

  ams4127 21:53 24 Mar 2003

Hope it works. It took me ages to find out why I couldn't get my HP printer to work, literally several days. I turned off the power management feature on the hubs and XP sprang into life and installed everything in a few seconds.

I have a suspicion that this was part of the SP1 patch because I didn't have this problem when I initially installed XP, only after an HDD problem which made me do a re-install, with SP1, before trying any USB devices.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires