USB Pen drive readable in every PC but mine

  coolteach 19:22 25 Nov 2005

I have a USB 2 128Mb flash drive that suddenly stopped working on my home PC (XP Home SP2). It comes up in My Computer and opens but is blank. Nothing can be saved or created there. It just displays a message saying that 'The system cannot find the specified file'. The drive works perfectly on XP Pro on my laptop, a different PC running XP home and on Win 2000. I have tried formatting the drive on one of the PCs wheere it works and put files on it but they still fail to come up on my home PC. The drive displays my given name on the other PCs but just comes up as a 'removeable disk' on the problem PC. Any ideas?

  smudge101 22:15 25 Nov 2005

I take it that you are running windows xp on the problem machine?

It sounds to me that windows is not mounting the drive correctly. In most versions of linux you have to do this manually but windows should detect and mount the drive automatically.

I am not sure of a work around for this, you could try going into Contol Panel/Administrative Tools and manually mounting the drive there.

If this is the problem then and it keeps occuring then I would think it would mean a reinstall.

You could also check to make sure all of your bios settings are as they should be, but I don't think the problem will be there.

If you could let me know the affected operating system it would be a help. Meanwhile I will see if I can recreate the fault on one of my machines.

  coolteach 22:37 25 Nov 2005

Thanks for the response. I'll have a look at your suggestions tomorrow morning. It is on an XP Home machine that I'm having the problem. However, the pen drive in question works in another XP Home machine!

What is confusing me even more is that I have just tried a different 128Mb pen drive in my machine (the one that is having the problem) and that one works!

This is very confusing.

  smudge101 11:30 26 Nov 2005

At least with the info you have given we can see that the problem is specific to the one computer (double check that it works ok in your other computer).

It is looking more like a problem with mounting the drive as mentioned before.

If you can mount it in the administrative tools/Disk Management then you should be ok.

It may be worth running a system file check on the affected machine as well.

  coolteach 15:01 26 Nov 2005

OK - now I'm even more confused. The current testing status is:

It fails to work in my own PC (Win XP Home SP2)
It works on an almost identical PC (same make e-machine) running XP Home too.
It works on my laptop (XP Pro SP2)
It works on another PC running Win 2000


This morning I tried it in my brother's PC running XP home and it failed to recognise it properly too!

  Joe R 15:13 26 Nov 2005


you could try inserting the drive into your own p.c.,
then right click on my computer, select manage, then select disk management, and see if the drive is listed here. (it may come under removable storage)

There should be a right click option to make the drive active.

  coolteach 21:12 28 Nov 2005

Thanks for your suggestions.

With the USB drive in, the entire computer management console just stops responding.

  Joe R 21:19 28 Nov 2005


is it a usb channel, on the back of your mobo,? or, a front mounted usb port.?

Could be that there is a cable wrongly connected, or maybe even a setting turned off, in your bios.

  smudge101 21:29 28 Nov 2005

If the management console does not respond with the drive in the USB port it could be a virus on there. I would do a good virus check on the pen drive (avast is good & free) and if a virus is found make sure to inform anyone whos computer you have plugged it into.

If this is not the case, I still think windows is broke and needs a system file check.

  SG Atlantis 07:47 29 Nov 2005

try rebooting with the pen drive still in the machine.

  coolteach 20:00 29 Nov 2005

As always, thanks for the suggestions. I'll check them all over the next couple of days and do the virus check with my avast virus checker asap!

Smudge101 - would problems with system files cause one pen drive to read properly and another not to behave properly?

Joe R - Thanks for the suggestions. I have checked the pen drive in all six USB ports (2 front, 4 rear) on my machine and have the same problem with each. A different pen drive works in these ports though.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?