USB PCI Card Not functioning

  Lerm 12:30 08 May 2008

I bought a 4 Port USB 2.0 PCI Card (manufacturer Dynamode) for my aged ASUs7V333 motherboard for the purpose of the external modem, which is connected via USB (no ethernet connection my board) in the hope of at least a trickle of better data transfer.

I slotted the card into a free PCI slot on the motherboard, WindowsXP (SP2, although maybe SP3 now) recognised the new hardware and even seemed to install drivers of its own accord. I tried to use the modem and then a flashdrive in the slots but they didn't work.

The card has been recognized and device manager has told me it is working properly. I then installed the supplied drivers and still the same. the card is installed, Windows XP has recognised it, the drivers seem to be installed but no devices are working off the card.

Any ideas much appreciated.

  Technotiger 12:42 08 May 2008

DO you have any other USB ports built-in to the PC?

  Lerm 12:53 08 May 2008

Thanks for replying.

yes, I do, but they are all USB 1.0 (there are two supposed 2.0 USB ports on this ASUS model but any chance of enabling them has proved labyrinthine. The BIOS needs to be altered etc. 2.0 was new when that model came out.

I have since rebooted the PC and after Windows at first recognising the hardware after the reboot it now tells me it doesn't!

There are now two '!' by the USB controllers list in the Device manager dropdown menu.

By the 'Standard Inversal PCI to USB controller'.
And by the 'VIA USB enhanced host controller'.

I am going to try and uninstall and reinstall, as instructed!

any more input welcomed.

  Technotiger 13:03 08 May 2008

Good luck with the re-install, I only wondered whether USB might have needed enabling in the BIOS - but obviously not.

As well as simply doing the re-install, I would also physically remove and then re-insert the card in the PCI slot.

  Lerm 13:17 08 May 2008

Thanks for the responses. I uninstalled as instructed, physically removed the PCI card and put it in a different PCI slot then rebooted and it is working fine. Windows located drivers and it is working now. Despite the initial problem, for £5.49 for four USB 2.0 speed slots, I cannot complain!

  Technotiger 14:25 08 May 2008

Grreat, thanks for your feedback.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017