usb mouse wont install

  hgrock 18:36 11 Nov 2009
Locked

Hi all,i have an acer aspire 6920 laptop mouse pad works fine but i cannot connect a mouse i get tge error that windows found the driver but an error occurred while installing, i have tried several different mouse, in all the usb ports same result. i know the ports are working.
any ideas folks?

  Technotiger 19:21 11 Nov 2009

I am not familiar with your particular laptop - but, perhaps you need to disable the touch-pad in order to use a USB mouse?

  hgrock 20:03 11 Nov 2009

its fairly new laptop 2 years it worked before but just stopped lately, i have tried disabling touch pad same result

  hgrock 20:08 11 Nov 2009

now i am getting unknown device installed successfully but the mouse wont move he cursor , cleaned the registry with regcure, result the same

  Technotiger 20:19 11 Nov 2009

If you are using XP and it is a USB mouse, then drivers should not be needed, other than the Generic drivers within XP!

I would try re-setting the USB Ports in Devices - Uninstall all of them and then re-start your Computer, XP should then re-install the USB Ports afresh!

  mooly 07:34 12 Nov 2009

Is it a cordless mouse ?
click here

  hgrock 08:29 12 Nov 2009

i am using vista home premium , the usb ports work fine with anything plugged into them except a mouse, i tried 3 different including a wireless funny it worked fine until about a month ago thinking of putting windows 7 on that may sort it. now even with the mouse unplugged it is still trying to install it

  rdave13 09:11 12 Nov 2009

Have a look in device manager for some yellow warnings under mouse. It's trying to install something that's not there. Disable it and try your mouse again. If all works ok then uninstall what the error shows.

  rdave13 09:22 12 Nov 2009

Another possibility is that Regcure has done something to the registry keys. If you can restore the registry, within the program, to the first backup then try that.

  hgrock 10:11 12 Nov 2009

mooly, thanks mate that solved he problem but instead of me doing it manually i ran the microso
ft fxit found here

click here

that did the trick, thanks folks

  Technotiger 10:16 12 Nov 2009

Grreat, thanks for your feedback.

Don't forget to Green-tick as Resolved.

Cheers.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?