usb mouse locking up

  the old man 09:06 30 May 2007
Locked

Have a vista system and all drivers up to date. Mouse ok when I first boot but after about 2 minutes the mouse locks and a message comes up saying an unknown usb component has failed. Batteries are new.
Does anyone have any ideas. works with normal mouse, ps2, borrowed from work. Want to sort this out and carry on using the usb one.

  Fingees 13:27 30 May 2007

I would suggest you try the mouse on another computer if possible.

Just a thought.

  the old man 09:22 05 Jun 2007

seems there is a problem with usb drivers. Installation has failed is the message if I go into the new features in vista.
I have disconnected all things from usb sockets but I still get messages saying a usb device has malfunctioned. I have tried to uninstall from device manager but as soon as I do that vista re-installs.
Seems I have hit a bottleneck and cannot find a remedy.

  the old man 12:56 05 Jun 2007

The following link is a very similar problem to what I am having. All the advice for uninstall in all under Usb in device manager is what I have tried to do as mentioned earlier.
click here

  the old man 11:00 06 Jun 2007

Have tried to uninstall all under usb in device manager again. Usb root hub had 6 entries and were uninstalled with no problem. There were 4 other entries that as soon as I uninstalled them within 30 seconds they were being reinstalled by windows with no option to stop the procedure.
Does anyone have any idea how I can totally uninstall and reboot so that the computer can reinstall the usb software.

  interzone55 16:53 11 Jul 2007

Did you find an answer to this issue, as I'm having the same problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

InVision Studio takes on Adobe XD and Sketch

Camera tips to take better iPhone photos

Comment transformer un iPhone en borne Wi-Fi ?