USB mouse in front port

  Jackcoms 07:11 19 Jul 2006
Locked

I've just exchanged my old ps2 mouse for a USB optical mouse.

The new mouse in plugged into the only spare USB port which is on the front of the tower.

However, every time I boot up I get a message telling me to use the mouse in a port on the rear of the tower.

I simply do not have any more spare USB ports (front or rear).

How can I get rid of the message at start up and leave the mouse in the front port?

  Taff™ 07:20 19 Jul 2006

Can`t you swap the mouse for something plugged in the back? Having the mouse in the front means the cable has to go to the back anyway. Swap it with the printer maybe?

  Jackcoms 07:30 19 Jul 2006

Printer is parallel connection!

I could swap it with the USB scanner but the cynic in me wonders if I'll get a similar message about plugging the scanner into a rear port!

  Gongoozler 07:31 19 Jul 2006

I wonder where this message is coming from. There is generally no difference between a front usb port and a rear one. Some motherboards have a usb header shared with a rear port, so it's is a possible that your front port can't be used at the same time as a rear one. For convenience, however, if all your rear ports are taken up I would recommend a PCI USB card. I have been very pleased with the ease of installation and reliability of this one click here

  Taff™ 07:50 19 Jul 2006

Try it! As a short term solution plug the mouse into a rear port and try the scanner in the front. I use a USB 4 port hub (Non Powered) from which I run a Printer, scanner and USB sticks. They are only a few quid - Mine came from Poundland - Yes £1!

Gongoozlers suggestion is the best one though - I can`t do that because I`m using a laptop!

  keef66 09:27 19 Jul 2006

what exactly does the message say?? How does the pc know the offending port's at the front?? What happens if you boot up then plug in the mouse? Does the mouse actually work via the front port despite the odd message?

  pj123 09:50 19 Jul 2006

My optical USB mouse came with a USB to PS2 adapter which I use to keep the front USB ports free.

If your mouse didn't come with an adapter you can buy one separately. Unless, of course, you want to use it as a USB mouse. In which case I would try Taff™s suggestion.

Have a look:

click here

  Taff™ 10:19 19 Jul 2006

If you want one of those adapters drop me a personal message I`ll put one in the post.

  Jackcoms 11:51 19 Jul 2006

Problem solved! Thanks for all your suggestions, as usual.

I simply switched the mouse to the rear port and moved the scanner to the front port - which is what I should have done in the first place!

Taff™ - thanks for your kind offer. In fact I already have a couple of those adaptors which I'll keep for possible future use!

  Jackcoms 11:59 19 Jul 2006

Just re-read your post.

In fact with the mouse already in the front port I get a message at boot which tells me to move the mouse to the rear port and/or hit F1 to continue or F2 for safe mode options. Too much like hard work to do that at EVERY boot up!

If I boot up and THEN plug in the mouse (at the front) it works perfectly but when I then re-start or reboot I get the same message as above.

To my mind it's all a bit odd. Never mind, all is now working well, although I have absolutely no spare USB ports.

In fact the mouse is running off an un-powered 4-port hub. I need at least one of the other sockets for pen drives, etc.

  Taff™ 00:40 20 Jul 2006

The reason that worked (swapping scanner to front port & mouse to rear) is that the "start up system" looks for Input devices first from "Primary USB devices" (rear ports). Once XP has loaded fully you can run most things off any USB port. Unless you activate a scanner as a peripheral device XP doesn`t even know it`s there! Unpowered USB hubs are recognised but the peripheral devices attached to them get lost in the boot up process - hence keef66`s post and answer from Jackcomms.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?