USB memory stick problem

  claluc 13:49 19 Jun 2007
Locked

I have suddently had the same problem on 2 different USB memory sticks, 1 is Tecnika 1GB, the other Kingston 2GB.
Was copying files to/from when error popup appered "Cannot create or replace(Name of file) The directory or file cannot be created"
Have tried different files from all types, still same result.
Also plugged in PC at work, very same story.
Files already saved read well.
1GB stick still has 450Mb free, 2GB one has 1,4 GB free, both brand new!
Can't be a problem of manufacturer, one bought from supermarket, the other online, both different makes but same problem?
I can't return for warranty as files copied are work documents containning sensitive data. The sticks were intended to be used for documents transfer to work from home.
No write protect switches present on either.
Any suggestion? I am really cross as have spent quite a bit of money on them.
If I save data on desktop, can they be formatted and how?
Thanks in advance for your help.

  keef66 13:57 19 Jun 2007

copy the contents to the desktop, in windows explorer R click the drive and choose format

  Sethhaniel 14:13 19 Jun 2007

have you tried to right click drive
select properties and see if read only is ticked
-

also memory sticks prone to static electricity - so earth yourself before inserting stick :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

Halloween Photoshop & Illustrator tutorials: 20 step-by-step guides to creating spook-tacular…

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?