USB memory not recognised/ not working

  shang1308 12:29 13 Jun 2007
Locked

Hi guys.

Apologies if i have repeated a thread which has been done a million times. Did a search- most were about the actual port though.

My memory stick appears to be broken. When inserting it into a USB port it makes the usual sound etc. However no windows pop-up appears and when i go into My Computer it is listed as Removable disk (E), and if you click on it, it says- 'please insert disk into drive e:'

Tried it on a few other computers and the same proble occurs. I assumed that it is broken.

The big question is- is there any way of restoring these or fixing them?

  A-Nonymous 17:21 13 Jun 2007

Could you tell me what make the USB stick is? I have a simular problem except mine appears in my computer and then it disappears and reappears. It repeatadly does this. But it only does it on some pcs.

  Diemmess 17:40 13 Jun 2007

You seem to have tried it on various PC's which is the sensible thing to do.

If every PC demands that you should insert disk in drive(X) then there seems no hope of recovery/reformat or whatever.

You could try just one more PC!

  A-Nonymous 17:43 13 Jun 2007

One point - is it an old one?

Check to see if it runs USB 1.1 or USB 2.0

It may run weirdly if you are trying to run a USB 1.1 product on a USB 2.0 pc.

  Fruit Bat /\0/\ 18:42 13 Jun 2007

Try formatting in device manager.

if it sees the disk but can't read it in my comp then a format may revitalise it, but of course you will lose any data on it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone