USB Mass Storage Device Problem

  CFC23 16:17 27 Dec 2008
Locked

My computer came with a built in multi card reader which has never worked correctly. I just gave up some time ago trying to make it work.
This Christmas I was given a Photo Frame and needed to load some photos on to it and tried once again to use the memory card reader. As before I was able to load the SD card with the pictures, and after, to read what was on it.
But! this would only work once and would not work again.
The computer says this is a USB mass storage device.
The only way I can get it to work again is to unplug the connection onto the MB and reconnect it,it will now work once more again for one time only.

I have read many posts on this site and on the MS site, it is a known problem but with no real solution.
Can anyone help?

  Pineman100 16:20 27 Dec 2008

When you unplug the card, are you using the "Safely Remove Hardware" function?

No guarantees, but it's worth trying.

  Technotiger 16:31 27 Dec 2008

Have a look in Devices - Right-click My Computer>Properties>Hardware>Device Manager then expand the + by Disk drives, the slots of your Card reader will each be shown as a Drive as follows ...

Generic USB CF Reader USB Device .... there will be at least four such entries, I have shown CF, but there will also be at least an entry for MS, SD and SM.

Right-click on each in turn and then on Update Driver.

  CFC23 16:43 27 Dec 2008

Pineman100
Yes have tried this before, It normally says that the device has been clicked for remove hardware but has not been removed,you must unplug and replug. Not what you would want to do each time from the MB!
Technotiger
Tried that,it finds no other drivers.

  Fruit Bat /\0/\ 16:48 27 Dec 2008

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here

built in multi card reader
do not use safely remove hardware just plug in the card and unplug when you are sure it is not being written to or read from.

  CFC23 17:34 27 Dec 2008

Thanks for that Fruit Bat /\0/\

Having searched the forum I have tried that,but it did not resolve the problem.

I have done many searches but have not found a definite solution to this. There are several instances of this problem on the various forums but it is still unresolved.
I can use my cards with other devises so it is no real problem,but I do not like to have a computer that I can not dominate!!

  Technotiger 18:19 27 Dec 2008

I added my own built-in Multi-card Reader, it came with a Driver CD. Perhaps if you look at the card reader's maker's website you might be able to get a later driver??

My own is click here

  CFC23 19:50 27 Dec 2008

Well, it was already fitted in the tower, but I have been able to find that it was On Spec Electronic Inc. No luck there either.

As I said before, not a real problem, but my latest gift made me have another"go".

It just annoys me that I can't resolve this silly problem!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017