USB internal card reader causes Explorer to close?

  PA28 13:15 08 Dec 2008

P5N-T Motherboard with Vista Home Premium. I have an internal Card Reader fitted with internal USB connection. Although this shows up correctly in Device Manager with 4 additional drives corresponding to the 4 slots, it recently became very slow in operation. Now it refuses to recognise a media card when inserted, and after a protracted wait more ofte than not it freezes Windows Explorer (not responding, etc etc). I did receive one message saying that Java was causing the problem. Since then I have swapped the reader with a known good reader and have also swapped the internal USB port to which it is connected. No change and I can't read any of my multimedia cards now.

I'm pretty sure that this is software related, but really don't know where to start looking beyond uninstalling Java and Shockwave (and quite a few web sites like these to be available). Any ideas please?

  PA28 13:16 08 Dec 2008

I should add that I've uninstalled and reinstalled the card reader itself with no effect.

  mole44 14:33 08 Dec 2008

try uninstalling usb ports and then restart pc,sometimes that works

  PA28 15:18 08 Dec 2008

All USB devices? I'm a bit nervous of that one, but if you think it might work.......

I did a System File Check (that's a lot more complex in Vista than in XP!!) and it came up with some corrupted files which it fixed, but there were some more that it couldn't fix and the workaround to that seems to be a complex copy and paste exercise, which I haven't yet attempted. I am hesitant to go in too heavy as everything else is working fine - apart from the port serving this card reader!

  PA28 16:40 08 Dec 2008

This is very odd. After the SFC, I went into "computer" and the drives couldn't be seen. I then accessed Device Manager and they were there. I tried to access properties and they failed to appear - and the drives also disappeared for a moment from Device Manager - and then re-appeared. If it wasn't that I am using a known good card reader I would blame that or the cable - but I know that it is good. So that leaves me with the USB connection does it not?

  PA28 10:06 15 Jan 2009

No developments on this so I purchased a new card reader. After connecting this to the header on the motherboard, the computer refused to complete its' POST! Any further suggestions here as I thinking now of a hardware problem.

  Graphicool1 13:03 15 Jan 2009

Hi PA28

You may need to update your drivers, download this Free software click here and run it. It will scan your OS and tell you if you need any driver updates and if there are any available you can download for free.

  CFC23 14:19 15 Jan 2009

I also have a internal card reader. I also have the same problems as you are experiencing,after a reboot the reader will work for one time,I can read and write to a card. However, after that it will not "see" any card that is inserted,it seems to think that something is still using it.
I can make it re-set if I pull the plug where it connects to MB but that is not a real cure.

I have had this problem from new,about four years,and just gave up on it having tried many searches and "cures"
All normal USB ports work correctly and so I can read any cards with a card reader through them, and this is what I do.
Sorry not to be of any help!

  T0SH 15:56 15 Jan 2009

One thing you could try is to unplug the card reader from the internal port USB then plug in the input cable for a powered USB hub into the internal port ,next plug the card reader into a port on the hub

This test should eliminate the problem being power related ,a not uncommon issue with internal USB ports

cheers HC

  PA28 22:43 01 Feb 2009

Outcome successful. Took the machine back to supplier (local computer shop, not one of the big chains) and they couldn't find a fault. However, as a precaution they fitted a new card reader foc and since then everything has worked as it should and machine is much faster as well .......

Don't ask..... I don't understand it either, but I'm happy.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Illustrator Sylvain Tegroeg created thousands of intricate line drawings for the mobile game…

Best iPad buying guide 2017

Comment télécharger une application indisponible en France ?