USB hub code 10 error

  grussell 20:37 15 Feb 2008
Locked

I'm having a problem whereby my laptop won't recognise a powered or non-powered usb hub. In the device manager/ properties menu it says 'This device cannot start (Code 10). All drivers are installed and up-to-date. There is no problem with the hub itself as i have tried 2 seperate ones. The USB ports do work themselves just not with a hub.

I have a HP laptop and using Vista Basic and have searched on this problem and a lot of explanations say to go into the registry and delete the upper and/ or lower filters of a particular section, i have done this and it still does not work.

Can anyone suggest what the problem could be?

  Fruit Bat /\0/\ 22:21 15 Feb 2008

Refresh USB Ports
Use Drive clean up to remove USB device drive info from the registry
click here
or
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

USB Permissions
Start - Run and type
regedit
Press OK.
Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB.
Right click on the folder and pick permissions. Set to ALLOW.
Do the same for:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USBSTOR

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017