USB Host Controller Problem

  BAC1-11 10:46 22 May 2004

While trying to re-install a sound card my opical mouse stopped working. Looking in Device Manager under USB Controllers I have two yellow flags against - SiS 700 PCI to USB Host Controller.

Is this a Mobo or Windows problem?

I'm running XP Home with a MSI 645 Ultra (MS-6547)Mobo.

I've uninstalled the the lines and re-booted but the poblem remains. Any idea's?

  Fruit Bat 10:53 22 May 2004

Niether this is probably a driver problem

Remove the controller from your system in device manager then let XP refind them and reinstall the drivers.

Post back if this doesn't cure the problem

  BAC1-11 22:20 22 May 2004

Thanks Fruit Bat but I tried that before posting here. I just tried it again with no change

To clarify - under the heading Universal Serial Bus controllers I have two entries for 'SiS 700 PCI to USB Open Host Controller' both have an exclaimation mark in a yellow circle.

Under properties - general - I have the message

'Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)'

Under driver details I have the following files


  BAC1-11 10:38 23 May 2004

Last night in an effort to fix this problem I tried to delete the above files in the drivers folder with the idea of copying the originals from the XP disc but about five secs after deleting the files re-installed thenselves.

On the XP disc version of the usbhub.sys file it is 28kb but the pc version is 58kb.

My plan now is to uninstall all my USB devices and see if on re-install it fixes the problem. Any comments?

If that fails can I re-install XP over the existing copy or is it better to format and start afresh (I don't really want to this)

  Fruit Bat 15:09 23 May 2004

Sorry about delay in reply but GP takes precadence over PC

No need to re install all of XP click here for sis usb drivers

  BAC1-11 21:23 25 May 2004

Fruit Bat,

Thanks for the SiS link but the site referred you back to the MS drivers.

The only way I could get everything working again was by a format & clean install. Before that I tried deleting the hardware, booting in safe mode, deleting the usb drivers and letting Windows re-install them (it recognised the h/ware) but it kept telling me the drivers were either missing or corrupted. I then tried to re-install Windows over the existing copy with the result was the same.

Looking at the drivers, now they are the the same as the ones mentioned in the thread starter.

Thanks for the suggestions though.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires