USB help

  Gemac 14:50 18 Sep 2007
Locked

Hi all,
I have a compaq notebook presario V2405US.
Firstly the usb ports don't seem to work, I get the
error message which states a usb device has
malfunctioned. I have tried everything to resolve that,
reinstalling drivers, and the devices themselves with
no luck.
So I bought a Belkin USB 2.0 Notebook card.
However, every time I plug it in, it's recognised and
everything is fine. Then when I plug in something like
a usb memory stick again it's recognised but when I
try and open what's on the stick I get an egg timer
then everything freezes, it's only when I unplug the
card that everything is freed up again.

It's so frustrating. Does anyone have any ideas?

thanks very much
Gem

  [email protected] 15:12 18 Sep 2007

A few things to try..

1.shut down windows,remove battery and mains lead so no power getting to the machine.
Leave for 30 minutes and connect up again.
try usb devices again

2.Refresh usb stack-uninstall everything under the usb heading in device manager and reboot
3.Have you added any memory?
Run memtest
click here

  uesquebeathus 15:13 18 Sep 2007

usb devices are often set with the power option controlled by the computer, which meens that if the computer senses that the device is not in use it switches it off, not an always convenient method, to change this go to start then
"Control Panel / System / Hardware / Device Manager/ Universal Serial Bus Controllers/Root Hubs /Power management
find
"Allow the computer to turn of this device to save power"

untick this option#

if this box is ticked and the system thinks the device is not working it will be turned off.

it is not a good idea to plug in (hot plug) or unplug usb or firewire devices while the computer is live and powered up without going through the remove devices procedure, which shows up in the bottom of the screen near the clock, right click the icon and click the shut down safely option. if you try to disconnect without doing this you can short out the usb connections damaging the motherboard in the process.

  Gemac 19:46 10 Oct 2007

hi guys, thanks for your suggestions.
I made sure the power management box was unchecked where it says allow to be turned off, and that didn't help.

Raven I did the first 2 and still no change.
Nope not added any memory.

If you have any ideas I'll be so grateful to hear them, it's so frustrating. I don't even get the error message now. It just doesn't detect anything, but according to device manager all is working properly.

Could it be a service pack 2 issue with xp?

Advanced peripheral configuration doesn't appear in BIOS would this be a problem?
Thanks all
Gx

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017