USB hard drive won't appear in Windows Explorer

  Pineman100 18:03 01 Mar 2006

In my last computer I used a second IDE hard drive (Maxtor 80GB) as a backup drive. When I recently replaced the computer I took the backup drive out of the old machine (without reformatting it) to use in my new computer. However, the new machine has no spare bay, so I have just bought a USB enclosure to house the drive.
I have set the drive's jumper to Master (it was Slave in the old machine) fitted it into the enclosure, connected it to mains power and to a USB port on the computer.
Windows (XP SP2) immediately found the drive and automatically installed the drivers for it (USB Mass Storage Device). The drive shows in Device Manager as working properly. However, the drive isn't appearing with a drive letter under My Computer in Windows Explorer.
Can you please suggest what might be wrong?
Many thanks.

  Diemmess 18:08 01 Mar 2006

Try CSL instead of Master

  Joe R 18:18 01 Mar 2006

Pineman100, can only reiterate what Diemmess has said.
XP will be confused, as you are telling it, it has two master drives.

  Pineman100 18:21 01 Mar 2006

Thanks Diemmess. I'm not familar with CSL - is the same as "CS Enabled"? The jumper choices on my drive are:-

J50 DS (MASTER) - currently set to this.
J48 CS Enabled
J46 Cap Limit
J44 (Untitled)
J42 (Untitled)

If you bridge the top pins between J44 and J42 you are set to DS (SLAVE) or Spare.

Thanks again for your advice.

  Fruit Bat /\0/\ 18:51 01 Mar 2006

You were correct, external drives have to be jumpered as master!

You will probably find that the last allocated drive letter is less than the letter require for your external drive.
i.e. last drive letter is F and fitted is two hard drives C and D plus two optical drives E and F.
your new drive is allocated the next letter G but this is unavailable.

click here

  Pineman100 18:56 01 Mar 2006

My fitted drives are only C (the system drive obviously) and D (CD/DVD optical drive). I sometimes connect my digital camera which is automatically allocated drive letter E.

I'm not sure I understood your post fully - are you saying that Win XP will only allow drives up to the letter F? If so, then it seems that this is still available on my system (as is E when my camera is absent).

Any suggestions what I should do, please?

  Steve- 21:10 01 Mar 2006

CS, CSL, Csel are all the same thing standing for Cable Select, set to this a special IDE cable tells the drive which configuration it should be in have a look at this click here - Obviously not a defined art!!

Try CS Enabled in any case.

I don't know if it is relevant to your USB Caddy but I have two drives in an ethernet network unit and a single drive in a USB caddy and they all have to be set to CS, the documentation with your unit should tell you if this is the case.

Incidently I am up to drive "K" on my system so "G" should not be a problem.

  Zeppelyn 22:06 01 Mar 2006

An alternative to a caddy if you have spare 5.25" bay is one of these.

Manufacturer : QUIETPC
Product : SilentMaxx HD Case 5.25"

Nice little unit that keeps HD cool too.

Cost £37 from Dabs

  Pineman100 16:18 02 Mar 2006


  Fruit Bat /\0/\ 18:15 02 Mar 2006

Windows can be set so as the last drive letter is D
I.E. you only can have a system hard drive c: and a CD drive.
you can have upto 26 drives A to Z (A+B always allocated to floppy drives)

Download tweakUI from click here

Install and run it click My computer click drives, put a tick in all the boxes down to Z and apply.

  Pineman100 18:44 02 Mar 2006

Thanks for that suggestion. I did as you recommended, but I found that all drive letters (A-Z) were already ticked.

Do you have any other thoughts on this puzzle?

Thanks again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Aardman's new YouTube channel to share the work of independent animators

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017