USB Hard drive not showing up in 'my computer'

  Lord Justice 11:13 22 May 2007
Locked

Hello all,

I have a USB hard drive that I need to use for back up purposes.

However it does not show up in my computer when connected. I know it is switched on etc and it is showing in device manager but I cannot see it in my computer in order for me to put files onto it.

How can I find out the drive letter? So I may use the command line to format it?

Regards

Ryan

  Lord Justice 11:13 22 May 2007

sorry win XP

  Jon-Dalton 11:53 22 May 2007

If you turn the HD off, and with the computer running plug in the USB lead and power the HD up, what happens? Do you get activity on the task bar showing that a 'mass storage device' has been detected etc. ?

  Lord Justice 12:05 22 May 2007

yes it is detected, but not showing in my computer

  Totally-braindead 12:08 22 May 2007

I can't remember exactly how you do this, you right click on the My Computer icon and goto Manage I think and then click on Disk Management but I can't recall what you do after that, there is some sort of option to enable the drive to be seen but I cannot recall where it is.

Hopefully someone else will give you the ending to what to do.

  Jon-Dalton 12:15 22 May 2007

There will be an option in device manager to disable the drive, which would obviously need to be changed if so, but I think you would see a red cross against entry in device manager for it if this were so. Does the USB icon in the system tray report that it 'cannot find driver' for the device?

  Stuartli 12:20 22 May 2007

In Device Manager, the external drive should be listed in Disk Drives.

Highlight it>right click>and then click on Update Driver.

  scotty 12:22 22 May 2007

I have seen a similar problem before. There was a conflict with two drives trying to use the same drive letter. If you go into Disk Management and Right Click on the USB device you wil get an option to change the drive letter. Change it to a lettr which is not used by any other drive (including network drives).

  Totally-braindead 22:26 23 May 2007

See if this helps he seems to have the same problem click here

  woodchip 22:32 23 May 2007

Right click My Computer\Manage\Disc Management Set the drive as active and format it

  Totally-braindead 22:33 23 May 2007

I knew it was something like that woodchip but I just couldn't remember what to do.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?