USB ERROR; 'PLEASE INSERT DISK INTO DRIVE J:.'

  puddylump 19:11 29 Dec 2009
Locked

Hello.

OK, so here's the deal. I was recording some video with an on-screen editor directly onto a 2GB FlashDrive. I'd finished recording what I need, and put the FlashDrive into my laptop. [OS Windows XP]. When I put it in, I found out the video files were the wrong format. So, I tried to close the window which had the video files in, everything froze up. I waited for a while, only to find a message saying something like:

"There has been and internal error in Drive D:. All data had been lost."

Great... I restarted my PC and tried again to transfer the files for conversion. This time, AutoPlay didn't come up so I went to My Computer. I found Removable Disk (D) so I clicked on it. I got a message which read:

"Please insert a disk into Drive D:."

I have changed the file path to J and there is no way to place a partition on the drive.

Is there a way to fix this? Or do I have to buy a completely new FlashDrive?

Thanks, Puddylump.

  Condom 00:12 30 Dec 2009

I think from what you have described that you may have removed the flash drive from the USB slot before it was ready to be ejected. The file contained on it might now be corrupted. This doesn't necessarily mean that your flash drive is finished as simply formatting it should restore it to working order but you will of course lose the data contained on it if you do this.

  puddylump 07:57 30 Dec 2009

Thank you for your help, but there is no way to format the disk, it just keeps saying that there is not a disk in Drive J:.

Anything else?

  mooly 08:06 30 Dec 2009

If you go to "computer" does the flash drive show ? If so is format shown if you right click the drive ?

  puddylump 08:12 30 Dec 2009

Yes, when I go to 'computer' the FlashDrive does show, and the formatting option is there. but when I click on it:

"Please insert disk into Drive (J)"

I don't know if this piece of info might help, but when it's been in the USB port for a while, it starts heating up.

  mooly 08:16 30 Dec 2009

Heating up means it's being "clocked" rapidly.
Does another drive work OK in that USB port... it should do.

You might have corrupted the drive beyond normal recovery.

  puddylump 08:29 30 Dec 2009

No, I'm afraid it doesn't work in another port...

It doesn't even work on the Desktop PC...

I think it's broken..

Do you know of a way to recover the disk? (I'm not bothered about the files anymore).

  mooly 08:43 30 Dec 2009

Hmmm... I think it's broken too.
I don't know of a way to recover it off hand... Google ?

  mooly 08:48 30 Dec 2009

If you have a play, I would suggest making a system back up first,
found this... amongst others
click here

click here

  puddylump 08:59 30 Dec 2009

I've just googled it and found several methods, from shoving up your rear, to using the command line method.

I didn't try the first option, so I tried the cmd method: click here to see what I did.

It said that there wasn't a disk in path 'J'.

Is this the end for my brand new FlashDrive? *sob*

  puddylump 09:38 30 Dec 2009

I tried both of the methods in the links you gave me, thanks for that. Unfortunately, neither of them worked..

But, now my FlashDrive thinks it's a HP Disk...

I think this is it for the little thing..

What do you think?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cachés sur Mac ?