USB Drive - No Media present

  Batch 09:41 20 Jul 2010
Locked

Have just bought a 64GB Corsair USB pen drive (arrived from Ebuyer yesterday).

On inserting the drive it goes through the usual process of recognising the device and comes up with a pop-up saying that the device is installed and ready to use. The device appears in Windows Explorer as Removable Disk (G:).

However if I click on the device a pop-up appears "Please insert a disk into device G:"

Also:

- Cannot format (says there is no disk in Drive G)

- In Properties Free Space and Used Space are all 0.

- In Disk Management shows G:, but "No Media" and no partionable area showing

- Have tried HP USB Disk Storage Tool (which also shows the drive as 0 capacity). This says there is no media in the device.

There isn't a secondary drive (e.g. H) associated with the device which occurs with some USB pen drive configurations.

Have also tried in my lappie with same results.

Does anyone have any other suggestions before I send it back as duff.

  Batch 11:22 20 Jul 2010

BTW, OS is XP Pro

  MAT ALAN 12:10 20 Jul 2010

click here

follow thread it may give you some more things to try, if that fails, i fear it's busted...

  Batch 18:56 20 Jul 2010

Thanks for the link. I'd already tried a (quite)number of things and tried some more from there.

In addition to the points I mentioned above, I think the crunchers are:

- It doesn't show in BIOS, e.g. as USB HDD (whereas other USB pen drives do).

- It doesn't show in Acronis True Image (when ATI booted sperately from its Linux shell).

- It doesn't work on any of the 3 PCs I've tried.

So, it looks like RMA time

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?