USB device needs formatting.....

  Picklefactory 10:16 13 Jan 2012

.... but it doesn't

Has anyone seen this issue before? I have a 4Gb Kingston flash drive that works perfectly in my desktop pc (XP) and on another laptop that I've tried it with (Win 7), but on a third, newish laptop (Win 7) it generates a message that the drive needs formatting. It only occurs on that machine, which I need to take on a business trip. Any ideas folks?

I know I can use a different flash drive (Also tried and possible) but I'd like to solve the issue if possible and understand why it has occurred. Cheers

  KRONOS the First 10:29 13 Jan 2012

Why not just format the USB after backing up anything you wish to keep, then see if it works on all three. I know I have had USB stick problems myself with some of of my 4 PC's seeing them others not, I have just put it down to the foibles of PC's where something or some software will work perfectly well on one PC yet on another virtually identical there are problems.

  Picklefactory 10:31 13 Jan 2012

Thanks Chronus

I'll give it a try and post back in a bit.

  Picklefactory 10:57 13 Jan 2012

Nope... that didn't work. Formatted on desktop, all went fine, reloaded the data, all still fine, removed, reconnected the drive, still no issue. Tried it back in the troublesome laptop (Dell), same response as before. I then tried formatting on the troublesome Dell and it couldn't complete the format either in quick or full mode. It just doesn;t seem to like that specific USB drive. I also tried a different flash drive in the Dell in the same USB port, and that one works perfectly.


  KRONOS the First 11:08 13 Jan 2012

Strange indeed. I have three USB sticks which are identical,they were bought as a three piece set, 2 work flawlessly on my Win 7 PC the third does not. On my wifes PC (Win 7) one works,and on the HTPC (Win 7)they all work. Strange indeed.

  Woolwell 12:04 13 Jan 2012

Assume that you have tried another port.

  Picklefactory 13:04 13 Jan 2012

Woolwell Yes but ta for the suggestion. The Dell also has a desk mount cradle with desk monitor which also has USB ports built in, and the same result when plugged into alternate laptop port or the monitor port.

Stupid laptop!!!

  Woolwell 13:08 13 Jan 2012

USB irritates me sometimes. I have a smartphone that connects to my desktop without trouble but refuses to be recognised by my laptop with the same OS.

  BRYNIT 13:17 13 Jan 2012

You could try formatting the drive in the Dell laptop and then putting the files back on from the desktop.

  KRONOS the First 13:39 13 Jan 2012

BRYNIT Thats what I suggested,didn't work unfortunately.

  Picklefactory 14:44 13 Jan 2012

It's interesting to see the issues you fellas have had with USB's in general. I don't use them massively, but I do have a few plus my smart phone, bluetooth dongles etc and I can hardly think of any issues I've had with any of them on various machines, so a bit of an eye opener for me.

Still none the wiser with this issue, but might just be one of those things

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?