USB Controller non existant

  pj1664 11:57 22 Dec 2003
Locked

Hi everyone, I recently puchase a USB mouse and when I connected it to the USB device at the back of my computer the system did not detect the mouse. I realise that the usb device controller is not in my device manager. I have gone into BIOS and enabled USB Mouse but still no avail. I have tried the same mouse on my daughters computer and It works. How do I get the USB Controller to function and appear in my device manager. I have 2 USB ports intergrated in my motherboard and also a PCI card with usb ports but nothing indicated on the BIOS the existance of a usb port.

  Big Elf 12:16 22 Dec 2003

What OS are you using? Have you installed the drivers?

  Gongoozler 12:20 22 Dec 2003

Hi jeet. What version of Windows are you using, and what motherboard do you have? It is quite possible that the USB motherboard drivers haven't been installed.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?