USB and Card Reader not working

  mrthewanderer 15:34 09 Mar 2009
Locked

My rear internal and front mounted USB ports have stopped working also my front mounted card reader lights up but is not being recognized.
I did change the motherboard battery a couple of weeks ago and the BIOS seems to say all is enabled?
Any suggestions would be appreciated.

  Technotiger 16:11 09 Mar 2009

Right-click on My Computer>Properties>Hardware>Device Manager and then under Universal Serial Bus Controllers delete ALL USB items.

Re-start your computer and all should then be automatically re-installed.

  mrthewanderer 16:58 09 Mar 2009

tried this and all re-installed but still nothing being recognized.

  Bris 17:50 09 Mar 2009

Remove ALL USB devices including hubs whether powered or not then do a cold reboot and plug in a flash drive and see if it picks it up. It may be just one device plugged in thats causing the problem.

  mrthewanderer 19:43 09 Mar 2009

Tried but still the same.

  Bris 19:56 09 Mar 2009

Did the problem occur as a result of changing the battery?

  Technotiger 20:41 09 Mar 2009

Check that you did not disturb any connections on the mobo, and elsewhere, when you changed the battery.

  mrthewanderer 10:36 10 Mar 2009

yes it was around the time of the battery change.
My printer is WIFI so only use the card reader and usb ports when needed ie transfering files etc..

  Bris 19:21 10 Mar 2009

As Technotiger suggests you may have disturbed some cables. The USB ports in the case are likely to be attached to USB headers on the motherboard, its possible that they have become loose or detached. The other possibility is that the CMOS values have changed by removal of the battery. Go into the BIOS and see if there is an option to "load defaults" if so you could try this. After replacing the battery did you have to reset the date and time? If so you will have lost your previous CMOS settings and that may be the cause of the problem in which case loading the defaults should correct this.
Also look in the BIOS for an item such as "Integrated Peripherals" under which you should see the USB controllers, make sure they are enabled.

  mrthewanderer 20:40 10 Mar 2009

I have tried all that has been suggested.
I am now thinking that the motherboard is at fault and will try another to see if it cures my problem.
Many thanks for all your suggestions.

  Bris 12:13 11 Mar 2009

Good luck with it 33oscar.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone