usb adapter connects and disconnects constantly

  johnhugh 09:31 08 Feb 2008

I have a Zyxell wireless modem with its own adapter as my lap top has no built in connection.
When I connect via the adapter it tries to connect, shows a strong signal but disconnects immediateley and keeps on doing the same,I managed to get it working once with a notice saying there was an application problem.(MICROSOFT USUAL NOTICE)
I have e mailed zyhell but no success there.The router works without interuption or signal dropping in wired mode. Any ideas please as to what I can try

  Kemistri 12:20 08 Feb 2008

That is a very odd error report for a piece of hardware: are you using management software from Zyxel? If you are, try it without and see how it goes. Uninstall the entire thing (hardware and its associated software), reboot/cleanup, and then install only the hardware with its driver (just plug it in and point Windows' hardware installation dialogue to the driver's location if necessary. This is based on the simple rule of thumb that Windows' WZC (and the Vista equivalent, which was renamed) is usually better at W-LAN network management than the supplied utilities. Why they are still routinely provided when Windows 98/ME is but a distant memory for most folk, I don't know! Seems like a waste of development costs.

Another tip: make sure that any problematic devices have a minimum of things in between them and in plain sight, away from big thick solid things. Straight lines are better than diagonals, with less floors/walls to deal with, since this is just nothing more than a high frequency radio signal.

  johnhugh 16:15 08 Feb 2008

Thanks Kemistri but still no go. I guess I just will have to be hard wired till I get a new computer

  Ashrich 19:41 11 Feb 2008

Just a couple of questions if I may , firstly , what is the spec of your laptop ( processor and memory ) ? and what encryption are you using , and have you updated the drivers to the latest ones for the adapter ? .


  robert22 22:11 11 Feb 2008

I had a very similar problem with an old dell laptop running Win98SE which drove me mad for month and occurreddespite numerous rebuilds and two adapters. Try disabling the creating an new hardware profile for a wifi connection and disable the ethernet controller in this profile.

  robert22 22:19 11 Feb 2008

This time in readable english...

Create a new hardware profile for a wifi connection in hardware profile tab of system in control panel. select this profile and disable the ethernet controller . Reboot selecting the wifi profile and try to establish a connection.


  johnhugh 07:23 12 Feb 2008

Thanks Ashrich, my processor is windows xp 3.06 ghz with 1 gb ram I have no idea of the encription

  johnhugh 07:29 12 Feb 2008


Thanks for all that but my computer skills are not up to it, thanks for taking the time re this, luckily it's only the convenience of being wireless that I am missing, the connection is good and fast when wired.

  Ashrich 19:23 12 Feb 2008

Do you have service pack 2 for XP installed ? If not then downlaod and install it , it will help with decrypting WPA security , also get the latest drivers for your adapter from ZyXEL , and try letting Windows manage the connection ( start/settings/network connections , right click on wireless adapter , select properties , click the wireless networks tab , tick the box for " Use Windows to configure my wireless network settings " )


  johnhugh 07:58 13 Feb 2008

Yes I have pack 2 and the latest driver, I have tried windows to manage and still no joy,
Thanks but thats it. I give up.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?