USB 3.0 woes on new PC

  Coxy_UK 06:45 19 Jan 2013

Built a PC with a Gigabyte Z77X-D3H mobo, 8Gb Corsair RAM, i5 3470, in a BitFenix Colossus case. Windows 7 64bit.

I have installed the latest USB 3 drivers but at best they run at USB 2 speeds and on occasion with large files copying has failed.

Also PC will not boot if anything is in a USB3 port, I have disabled boot from USB in Bios.

Any help would be much appreciated. Cheers

  Fruit Bat /\0/\ 10:16 19 Jan 2013

A stupid question but --- you are using a USB3 device and USB3 cable?

  Nontek 10:16 19 Jan 2013

USB3 will only run at that speed if the hardware connected is also USB3. I am not sure that there is much USB3 hardware available at the moment.

Sorry if I am only 'teaching' you to suck-eggs,as they say!

  Chronos the 2nd 10:29 19 Jan 2013

What the previous poster have said immediately sprung to mind.

  nickf 11:24 19 Jan 2013

There could also be conflicts with the USB drivers . I have had similar problems trying to install S/W on customers PC`s .

  Coxy_UK 12:26 19 Jan 2013

Hi yes it's a 64gb USB 3.0 stick that I am primarily trying to use.

The PC will with my Bluetooth dongle in a USB 3 port so it seems only storage devices stop it from doing so.

  Coxy_UK 12:38 19 Jan 2013

Ok so I loaded default settings in Bios (very noob of me not to have done that already) and the PC booted with the stick plugged in.

I tried copying the same hd video over which took 4:00 mins in USB 2, in the USB 3 port it took 3:10 and the first half was done in 1 min so it dramatically slowed down as it copied.

  Coxy_UK 12:48 19 Jan 2013

Tried the same file to the stick from my sata3 ssd and it took the same time.

I then copied from the stick back to the ssd and it took 1:30 remaining at a steady 74-75 mbps. I t's just the write speed then I assume that starts high and quickly falls to around 40 mbps.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?