USB 2s only work through an old USB 1 adapter

  regburns 18:01 13 Dec 2007

This is daft.

My modern PC used USB 2 until today. I think that I had made a mess of installing my new printer, and somehow damaged the registry.

The printer, which worked well for a while, and still works with other PCs through a switch box, started to act erratically, and eventually stopped.

I removed all the drivers through device manager.

I installed a PCI to USB card with no success.

Then, I used an old USB 4 way adapter, and I suspect that it changed my USB2 to USB 1.

It works well, on all of my, now 10 USB ports. More, my memory stick had also stopped working, but it now works perfectly, through the adapter.

I am sure that I have sorted this out by reducing my USB2s to USB 1, and I can live with that, but I know that there must be a software trick I have missed.

Any suggestions?

Regards Reg

  skidzy 18:24 13 Dec 2007

Check Device manager to see if the usb Host Enhanced Controller has been disabled.

This sounds like over loading,is your psu up to the job ?

  regburns 18:35 13 Dec 2007

I did try to work around it by disabling the Enhanced controller, but that did not work, so it is enabled again.

i have only got the printer and a little web cam on the USBs. By the way, I forgot to say that the web cam had continued to work throughout, but it is an old one, and may be only suitable for USB 1.

  skidzy 18:43 13 Dec 2007

First thing i would try;

Uninstall everything under USB in device manager and reboot,let xp or Vista whatever your os is install the generic drivers.

  regburns 18:47 13 Dec 2007

I'm sorry, I forgot to say that i had uninstalled them all and reinstalled them with Win XP

  skidzy 18:53 13 Dec 2007

Ok,you do have SP2 installed ?

If you have reinstalled the os,its possible you may need the sp2 update that is required for usb 2.0

  regburns 18:56 13 Dec 2007

I do have SP2 installed, but do you mean that I need to to somehow update it?

  skidzy 19:22 13 Dec 2007

No,if its installed you should have usb 2.0

Im stuck on this,maybe others have some ideas.

  Coffee Adict 20:29 13 Dec 2007

You could try Fruit Bat's solution which worked for someone else click here.

  skidzy 20:44 13 Dec 2007

That has been tried already (see above).

  Coffee Adict 21:48 13 Dec 2007

Ooops, more coffee methinks! Brain not in gear.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?