usb 2.0 upgrade problems

  rossss 15:38 14 Jan 2009
Locked

Hi guys. I have an 'ASRock k8 upgrade nf3' motherboard which i believe has the nvidia usb controller. Im using windows XP with SP3.
I have been using the usb ports up until now with no problems, but when i checked the device manager i noticed it never said usb 2.0 anywhere, and it hasn't been going very fast so i presumed at this point that it was just usb 1.1 that was being used. Anyway i tried to upgrade it and usb has stopped working altogether now, i have the yellow warning icons beside the usb entries in the device manager. I've tried to roll back the drivers with no luck and i've downloaded drivers from the internet with no luck. When i just click 'Upgrade Driver' in the device manager it says it can't continue because it couldn't find a better match for the hardware than what's already installed.
Its a bit of a pain because i just got a new usb stick thus the reason for trying to upgrade it. I can't roll back the system to a previous state because i never had System Restore turned on, its a fairly new windows installation so i'm still in the process of setting things up.
Any ideas anyone?

  iscanut 15:49 14 Jan 2009

When you say you tried to upgrade it, what did you do ? You would normally have to install a new USB PCI card to upgrade to USB2. It is not a software thing !

  rossss 15:56 14 Jan 2009

well if you have usb 2.0 hardware and its registered on you're system as 1.1 then you need to upgrade the drivers for it, thats what i was trying to do. I have usb 2.0 on the motherboard and its enabled in the bios, SP3 is installed, but it wasn't displaying as usb 2.0 in the device manager, it was just displaying usb, which would indicate it is running the 1.1 drivers?
But i cant even roll back the drivers to what it had originally, nothing works lol!

  Graphicool1 17:57 14 Jan 2009

Hi Rossss

iscanut was correct in his assement Regarding Ugrading. I think you may be getting confused with Updating. Two words very similar, easy to mistake.

Download the Free DriverMax at :-
click here
It will check all drivers on your OS and tell which ones need updating and if they are available for download.

  Stuartli 18:37 14 Jan 2009

You should have USB2.0 drivers as you state your operating system is XP and Service Pack 3.

Try reinstalling the motherboard drivers (latest version) from the ASRock website.

Normally Device Manager will indicate Enhanced alongside USB controllers to show USB2.0 is available, although some/most manufacturers supply their own for particular USB products.

Also see:

click here

The USB website:

click here

  rossss 00:03 15 Jan 2009

Ah i see, sorry i thought updating would mean the same as upgrading since they would normally be very similar, now i see that there is a difference when discussing this sort of thing, my mistake.
I downloaded DriverMax like Graphiccool1 advised, it updated the "Standard OpenHCD USB Host Controller" and one of the 3 lines in Device Manager had disappeared, but the other 2 are still there with the yellow warning icons; also, my usb ports still wouldn't function.
I've downloaded and installed the motherboard drivers like stuartli suggests, but theres no change.
To be honest i would be happy with the 1.1 drivers if i get them working again, 2.0 would be ideal but just to get usb working at all would be a huge relief right now.

  rossss 01:08 15 Jan 2009

Im gonna get to bed, sick of 'playing' around with it lol.
Thanks for the input guys, its much appreciated!

  iscanut 09:17 15 Jan 2009

Buy a cheap PCI USB2 card ( about £10 ), install that and use the new USB ports and see what happens.

  rossss 14:26 15 Jan 2009

Good idea iscanut, think i'll do that, thanks for the idea.

  gnomee 15:48 15 Jan 2009

refering to your usb 2 drivers,
remove the usb itemsfrom device manager
restart and windows should show you the way to get back to your usb drivers
i have win98se and to get a ig stick to show up i had to manualy select mass storage driver from windows setup prompt,
good luck
from ipswich uk

  rossss 15:51 15 Jan 2009

Hi gnomee, i tried that, tried all sorts, i even took note of which drivers they were using in device manager, removed them from the device manager, backed up and deleted them from the windows/system32/drivers folder, then restarted, somehow it just created them again and used the newly created ones and everything was the exact same. I couldnt get anything to work. I'll pick up a pci>usb card in the next few days and try that.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017