USB 2.0 PCI card running at USB 1 Speed

  tigernick 15:49 11 Mar 2006
Locked

I have recently bought a USB 2.0 PCI card to use in my PC running XP Pro sp2. I installed the card and believe it to be working properly as it supports some devices, the word 'enhanced' appears in the device properties which i understand to mean USB 2.0.

The problem occurs when trying to use my new external hard drive which has USB 2.0 connectivity. When connecting into one of the USB 2.0 ports on the new PCI card I get a message saying "This device can perfrom faster if you connect it to a USB 2.0 port. For a list of these ports click here". I then click the balloon and am presented with the USB 2.0 enhanced controller and the 6 USB 2.0 ports, all apparantly working correctly! The hard drive does work, but not at the higher speeds, and I have tried it in all of the available ports.

I assume that the hard drive thinks its connected to a USB 1 port, which it is not. Or it has the wrong drivers, which I have updated, and are said to be up-to-date. I am at a loss as to what is going on and would really appreciate any advice??????????


Thanx

  smokingbeagle 16:02 11 Mar 2006

Check that the USB cable is for USB2.

Try re-installing the PCI card.

  Stuartli 16:15 11 Mar 2006

I use several "USB1" cables with USB2 devices with no apparent speed loss...:-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

See the work of famous artists playing with toys

iPad Pro 10.5in (2017) review

Comment faire une capture d’écran sur un Mac ?