usb 2 ports running at usb 1 speed

  joethebow 23:23 12 Dec 2005
Locked

My USB 2 ports were working quite happily at the correct speeds. Then I reformatted my windows partition, reinstalled XP inc SP2, and did all the updates.

Now the USB 2 is seen as USB 1.

I visited Microsoft Knowledge Base and they say it's a known problem that was fixed in the updates. I downloaded all the updates available, no help.

Tried my mobo disc only Win98 drivers.

Tried mobo website, it doesn't recognise mobo as one of theirs.

Mobo - WinFast 748KAA

  joethebow 23:51 12 Dec 2005

Just checked the BIOS, I have the latest BIOS installed. Also tried reloading the USB Drivers, even deleated the Devices and let them reinstall, still running like a slug.

  phono 01:51 13 Dec 2005

Do you have the correct, latest, drivers for your mobo chipset installed?

  joethebow 22:48 13 Dec 2005

After spending an hour on Knowledge Base and trying to download all manner of USB 2 Drivers, none of which did anything I went back to the BIOS. Hidden 3 layers down was... USB2 Enable/Disable! I now have USB2 working properly.

  phono 23:50 13 Dec 2005

Good on you, perseverance pays off.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?