usb 2 host controller

  mrh 19:28 11 Jun 2003

Have a asus a7v333 mobo - 2.4ghz amd- mobo comes with 4 usb2 connections - when installing explorer mouse - discovered usb2 connections was not working - removed controllers and re-booted - now mouse works and apparently no problems - here then is the query - no usb2 host controller shows up in device manager -listed is micosoft integrated usb hub-usb printing support-usb root hub(x5)-via rev 5 or later usb universal controller(x4) and finally Via usb enhanced host controller -have sp1 installed with xp home-
should usb2 controller show up?
thanks in advance

  Despicable Desperado 21:24 11 Jun 2003

It will just show up as USB not USB2

  mrh 21:37 11 Jun 2003

thanks for response - i was only a bit confused - because on originally installing motherboard - prior to sp1 -=i loaded drivers for usb2 from disc from asus - this showed up as usb2 host controller - i have since re-formatted with sp1 - assumed with usb2 support with sp1 included - i shouldn't install additional drivers - i have since loaded these drivers with the result of dead usb connections - uninstalled - connections fine but concerned (as original posting explains_
thanks again

  ams4127 22:35 11 Jun 2003

I've just checked mine and the USB2 Host Enhanced Controller shows up in Device Manager as well as the original USB1.

  BillEmm 00:07 12 Jun 2003

The A7V333 comes with USB 1.1 and USB 2.0 controllers. The USB 1.1 (Rev 5+) are contained in the South Bridge chipset while the USB 2.0 comes off a separate VIA USB 2 chipset.

There are four USB 1.1 controllers in all each supporting a port (2 on the backplate and two off a motherboard header).

I believe its is only one USB controller contained within the separate USB 2.0 chipset and this supports four ports (as in the case of the 1.1 - two on the backplate and two on a header).

These should show up on Device Manager as 5 'devices'(4 x USB 1.1 and 1 X USB 2.0).

  mrh 05:07 12 Jun 2003

again thanks for the response - i presumely do have a missing usb 2 controller - ?

  mrh 15:52 12 Jun 2003

if the usb2 comes off of a seperate via usb2 chipset - if the usb connection is working - is it safe to assume -
1 the connection even though connected to a 1.1 mouse is fully usb2 compatable

  BillEmm 16:43 12 Jun 2003

I,m not sure I understand your question(s).

In Device Manager you ought to have (at least) five entries as follows:

VIA Rev5 or later....Universal Host Controller
(4 of these which are USB 1.1) and one of the following:

VIA USB2.0 Enhanced Host Controller.

From what I understand you do not have the USB 2.0 entry which suggests you do not have USB 2.0 support available to you.

Your USB 1.1 should be OK.

Do a search on your system drive for 'ousb2hub.sys' - without the quotes to ensure that you have usb 2.0 drivers listed somewhere on your system. They should be there if you have installed SP1.

It might be worth checking your BIOS to ensure that 'USB Legacy Support' is set to [Auto] and 'USB Function' is set to [Enabled]. I'm not convinced the former has anything to do with your problem and if you have USB 1.1 support then the latter will be OK. Check anyway and follow up with a re-install of the USB 2.0 drivers.

Until you activate USB 2.0 support you only have USB 1.1 available to you and only off the USB 1.1 ports. If I remember correctly the two upper USB ports on your backplate are USB 1.1 while the two lower ones are USB 2.0.

USB 2.0 devices can run off the USB 1.1 ports but they will only operate at USB 1.1 speeds.

USB 1.1 devices will operate at their designed speeds off any USB port - given that the controller for the port is functioning.

I hope this helps.

  mrh 17:11 12 Jun 2003

hi billemm
my original problem was - i tried to install explorer mouse(usb1) on one of my usb 2 connections - no success (usb) dead - I then uninstalled my usb2 driver and re-booted -
result was my usb mouse worked (off of usb2 connection) apparently no problems anywhere-
my dilema was that the usb2 host controller does not show up in device manager(see earlier in message)
I originally installed asus usb2 driver but since installed sp1 - which i thought added usb2 support.
my query was do the usb2 host controller have to show up in device manager
i have ousb2hub.sys on my system
thanks in advance

  Despicable Desperado 23:12 12 Jun 2003

SP1 does not add USB2 support - the drivers you install add the support. I have an add in USB 2 card and onboard USB1

  Despicable Desperado 23:15 12 Jun 2003

Sorry ignore my last posting - was not supposed to be sent. Checking something and must have clicked to post!!!!!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?