US Robotics ADSL Router 9003

  qidas 23:45 05 Mar 2004
Locked

Has anyone used this router before? Product Details below

It had been working fine but now I cannot seem to connect to the internet. It says it is connected. I even tried another similar hub from my friend hub and got the same problem.

In the end I used the USB modem that I got from Tiscali and was able to connect to the internet.

What can possibly be wrong? Even the settings are fine. It just suddenly stopped working.

USR9003 SureConnect ADSL Ethernet/USB Router
(USR019003)

click here

Any suggestions would be most appreciated

Cheers

  Josh123 18:48 01 Dec 2004

I have had a US Robotics SureConnect for a year, connected to F2S. It has worked fine via the USB port, BUT I have recently tried to add another PC on one of the LAN ports, and I can't get that connection to work.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

How secure is your Wi-Fi?

AMD vs Intel: we put the most powerful desktops for designers and artists head-to-head

iPhone tips & tricks

Les meilleurs ordinateurs portables 2017