Upgrading to Win98 drive-letter assignment

  docj 12:58 30 May 2003

I am upgrading my friends Win95 to Win98. I am using a 98 boot disk and all goes well until I get to the command prompt to install from the CD.
She has the normal drive C, then a back up drive D, then the CD drive as E.
I have tried E:\ setup and F:\ setup but with the former I get 'bad command' and with the latter I get 'wrong drive' or something like that.
I have read somewhere that it may be a registry problem with regard to the assignation of drive letters but I have no idea as to how to go about rectifying this.
I am not too hot on DOS commands either so if you could put any anwers in with the correct command lines for me to copy that would be a great help.
I have also read of a way to get round this by copying the Win98 files to the hard disk but I am not sure what I should type in for the path lne to tese files.
Any help appreciated.

  spikeychris 13:10 30 May 2003

When you say you are upgrading, are you using an upgrade Win98 disk? Have you typed d:/setup?


It sounds to me like the CD ROM drivers have not been loaded.

Normally with a Win98SE boot disk, you get a boot menu so that CD ROM support can be loaded, but I don't think you get that option with early Win98 or Win95.

Try here if you can't get hold of a Win98SE boot disk. click here

  krall 13:41 30 May 2003

If Win 95 is still existing and you are installing WIN98 upgrade there should be no need for you to use 98 bootdisk. Just boot up 95 normally and then insert upgrade disk in drive E and setup should be automatic.

  docj 14:41 30 May 2003

I am sorry I should have been more specific. She only has the Win98 full OEM disk which came with some other disks when she bought the computer second-hand with 95 loaded.
I am getting around the system's refusal to accept the OEM disk by renaming win.com to win.old and then booting from a floppy which I made on my computer with the 98 OEM disk. I read in another help forum that this should work and it does until I get to the setup command. I imagine that the D back up drive is a partition.

  Megatyte 15:03 30 May 2003

Try typing it without the space before Setup.

With physical drives C & D, Ramdrive will be E so your CD should be F



  docj 18:33 30 May 2003

I did try F but that was the drive it did not recognize. I will try all possiblities without the space as you suggest. I will also check to see if the CD drive is actualy being recognised from the boot disk set up. I have downloaded another boot disk from the site mentioned above and also a disk from Ultimate Boot to see if that makes any difference.
Another option I suppose might be to assign another letter to the CD drive (like Q for instance).
Could I boot directly from the CD if I set that up in the BIOS I wonder? I cannot try any of this at the moment as she lives quite a way from me.

  docj 19:37 31 May 2003

There were no CD-ROM drivers loading from the boot disk but I was able to install by copying the cab files to the hard drive

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?