Upgraded Router Firmware - cannot connect to ISP

  kevvyb 23:12 12 May 2006

Oh hell. Upgraded my router firmware and all seemed to be going well with configuration until I did a restart and seemed to lose my network connection. Appears that router is now not establising a connection with my ISP. I have enabled DHCP and enabled automatically detect settings, disabled use proxy server.

Have also enabled TCP/IP which is set to detect settings automatically and enabled netbios over TCP/IP as I have a static IP address..

The really odd thing is that I can establish contact with the router but I cannot now change any settings as I keep getting prompted to connect and of course, when I do, there is no connection. This appears to be preventing me from getting anywhere.

Router is synced but no online connection.

Running IPConfig was giving very odd results whcih I did not note and this has now changed to the following which I think is still wrong:
Connection Specific DNS: blank
IP Address: My IP Address
Subnet Mask:default
Default Gateway: My IP address

I am running XP SP2 no problems until this evening. Fully virus scanned, multi spyware portected and firewalled.

Router is 3Com 3CRWDR100A-72 and I just updated to the October 2005 firmware release v2.06

In addition:

Subsequently looking at the status details of the connection reveals the following:
Physical Address: Blank
IP Address:
Subnet Address:
Default Gateway, DNS and WNS all blank

I have swopped to another system that has not been used since installation and the connection is not made there either. I have cross checked all settings. Status details were different. I think my IP address and a default subnet. So I don't think it's corruption of system files or anything like that.

The only thing that has occured to me just now is that I (probably stupidly) had a laptop connected to the router as well as my desktop when I upgraded the firmware and attempted to reconfig the router. This was at the time connected through said LAN over VPN to my work servers. I cannot beleive I was so stupid as to do this. Has this maybe confused the router in some way? Starting to feel to me like I now need to manually configure as the router is not detecting settings automatically.

Am at a loss as to where to go from here. Any ideas on this very gratefully received.

I ahve also restarted and reset the router to no avail, having unplugged it and powered down.

  ade.h 23:20 12 May 2006

One thing that you should always do, in case you need to revert to the previous firmware, is make a backup of your configuration. I have a manual for your router, but it's on my other PC, so I can't refer to it right now. But hopefully, you did do that, right?

click here and download one of the earlier listed firmware revisions. Install it and with luck, you will find that it will work and you will only need to configure it again. First perform a factory rest from the UI if you can.

  kevvyb 23:34 12 May 2006

Thanks for that but I did save a backup and tried to revert to it but becuase the interface to my router does not seem to be functioning without requiring a connection (?)I can enter new settings (including the upgrade [reversion] to other firmware but it's not letting me save anything so I can get anywhere. It's really odd.

  ade.h 23:43 12 May 2006

I didn't explain it clearly in my previous post, but you will need to revert back to the previous revision - if it accepts it of course - to be have a chance to use the backup. Even then, there are no guarantees.

Hindsight is 20-20, but the golden rule is: Never upgrade any kind of firmware if the device currently works. The risk is really too great otherwise.

Hope you get it sorted.

  Dipso 00:08 13 May 2006

The fact that the laptop was connected at the time of the firmware upgrade may have corrupted the upgrade. My router upgrade instructions clearly state that it is important not to interrupt the connection during the upgrade process for this reason. The last time I performed an upgrade, I disconnected the modem cable to be sure.

ade.h - I don't agree with your "golden rule" I'm afraid. Firmware upgrades can be advantageous if performed correctly.

  kevvyb 00:11 13 May 2006

will thatmean that the router is ready for the bin?

  Dipso 00:21 13 May 2006

Not sure...I have a Netgear, they provide a Recovery Utility for failed firmware upgrades. I wondered whether 3Com hadsomething similar.

Are you not able to try the upgrade again, is the inability to connect to the router interface preventing you?

Was it FW v.2.06, I did notice this if so, "Special Instructions: A reset back to factory default is necessary after firmware upgrade. Previous configuration backups must not be reused with the new firmware"

  The Spires 00:22 13 May 2006

Does your router have a reset to factory settings button hidden on it.

  kevvyb 00:51 13 May 2006

have tried reset does not seem to do anything.

I have realised that in trying to revert to the old firmware I mistakenly used the setting config backup. Stupid me. Although one would have thought it might just be rejected as it wasn't a firmware backup. I was still getting into the web interface at that point but now cannot even get into that! So looks like I'm stuffed. If I could get back in I could try the old firmware of which I have a saved copy.

  Hertz Van Rentyl 09:04 13 May 2006

What sort of reset have you, only the BT one has a hole where you insert an unfolded paperclip, you have to press a long time till the lights go out, can take up to 20 secs.

  woodchip 09:24 13 May 2006

Have you tried turning the router off for ten minutes

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?