Upgrade HDD Drive. XP won't Boot..

  Dumfy 21:31 17 Mar 2008

Hi All,

This has me baffled. System is working fine and boots to my original 160GB HDD. Wanted more space so now have a formatted 320GB HDD.

I use Drive Image 7.0 for back up purposes and image archiving, so used this software to perform disk to disk copy. All this completes, disconnect "old" sata drive, but system won't boot from new HDD. The same thing happens when I restore my last image to the new drive instead of using "copy drive."

The messages displayed are "corrupt or missing HAL.DLL" or "Load boot media from where to boot from"

Here's what I've tried so far without success..

Re-formatted new HDD and tried again.
Booted with XP CD to Recovery Console. No Windows/OS detected, so can't use FIXMBR, FIXBOOT, BOOTCFG /Rebuild etc.

Also, no windows installation shows in the Recovery Console - just Unpartioned space. At one time, I did manage to see the windows installation for selection, but it demanded and Administrators Password. Have never created one of these and even leaving it blank and just hitting "return" it kept asking for a password.

Recently I have been using Bootskin software from Stardock.com and have read this can cause issues. I uninstalled this and cleared it all out. "Old" HDD still boots perfectly ino XP. Tried Drive copy again - still won't boot with new HDD.

What I don't understand is..
How can I have no issues in booting up with the "old" HDD and the system behaves perfectly, but when I do an identical Drive to Drive copy, the new drive won't boot?

Finally, with just the new HDD installed and freshly formatted, if I load the HP Recovery CD that came with the PC and let it run through, the new HDD then works and boots to windows - though the system is then back as it was out of the box 2 years ago. I wanted to avoid this and carry on from where I was but with a larger drive.

Sorry this is long winded and congrats if you got this far - but I wanted to get as much info on here as possible.

For the record, it a HP Pavillion PC running Media Centre 2005.

Hope you can help with this

Best Regards


  Fruit Bat /\0/\ 22:34 17 Mar 2008

1. are you plugging your new drive into Sata 1 port on your motherboard.

2. have you removed any cd floppies from the drives?

3. Hal.dll missing or corrupt click here

  Dumfy 21:41 18 Mar 2008

Thanks for that, Fruit Bat /\0/\

From further reading, it seems I need to remove the dynamic disk overlay from the drive in order to get it work properly. This may also explain why Windows Explorer sees the drive as 127GB, but Disk Management sees it as the proper 320GB (actually it reports 299GB so where's the other 21GB .. taken up by NTS formatting? Seems a large amount to me.)

Anyway downloaded the disk utilities prog from the Western Digital site, installed and ran it and it confirms a problem with the DDO layer and to remove it - but this must be done in DOS. Download and created the said boot disk - but all options to remove the DDO layer are greyed out and can't be selected.

So, would a "zero fill" effectively do a low level format of the drive and get rid of the DDO for me?

Anybody been this route or have alternative solutions?

Running Media Centre 2005 OS with SP2 and all updates.



  DieSse 22:58 18 Mar 2008

"So, would a "zero fill" effectively do a low level format of the drive and get rid of the DDO for me?"

Yes - though it really is a zero fill, and really not a low level format (which you cannot do on modern drives).

If any of your drives is a Seagate drive, you can download Disk Wizard to both set up your drive, and clone your system to it. It's a stripped down version of Acronis True Image.

  Dumfy 10:10 21 Mar 2008

Thought I'd post this and tick it resolved. The info may be of use for somebody else in the future.

The Zero Fill worked on the Western Digital drive and eliminated the DDO layer.

However, still couldn't get the drive to boot from either a disk-to-disk copy or by restoring an image.

After a lot of messing about, I discovered that the problem was software I was using for copy and restoring - namely Powerquest Drive Image 7. I never realised that it wasn't designed to work with drives as large as the 320GB I was trying to install.
Instead I used Paragon Hard Disk Manager 8.5 and it worked a treat!

At least I know a bit more about hard disks now!

Thanks for the inputs


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?