Updating Tiscali (old Sagem modem) to WiFi

  RichieSumner 17:13 01 Jun 2008

I have Tiscali Broadband via a BT phone line. It connects using the Sagem modem which came with it. The wire from the modem connects to the PC's USB port.

I want to update to WiFi, so that my laptop can access internet on wifi, but the PC using ethernet cable.

I bought a Belkin ADSL modem router (hopefully correct, not cable?).

Uninstalled Tiscali on my PC. Removed the modem, linked up the new Belkin. Connected it to phoneline using ADSL and filter (same as Sagem). Then connected it to the PC via ethernet cable (previously USB).

I turn on PC, eneter the 192.x.x.x address and set up the 'internet WAN'. I added the username, password, select PPPoE etc. When i click 'apply changes', according to the manual, the 'internet connection' reder at the top right of the page should go from a red 'no connection' to green 'connection ok'. But it doesn't!

If i go to a web page, it doesnt recognise an internet connection. I have not even tried the WiFi - just trying to get online.

A few basic questions - do I need to install drivers for this Belkin? I add the CD but it just has a PDF manual?

Do I need to add a 'network connection' in addition to adding my tiscali username and password on the router set up page?

Any help would be much appreciated - struggling here!!!


  brundle 17:20 01 Jun 2008

I may be wrong but I think you need PPPoA for ADSL/Tiscali.

Remove the USB modem drivers, reboot, try again.

  brundle 17:26 01 Jun 2008

Does the Belkin show `Connected`, does it show IP addresses it has got from the Tiscali server?

click here

The image is from a Belkin that suddenly stopped working with AOL (don't worry, nothing to do with the router itself) - in the image, it has detected a 2mb ADSL signal, but hasn't actually connected and received IP address info. There should be a bunch of numbers in the fields on the lower right when it's connected. Then you can tackle the network setup (if required) on the computer(s)

  RichieSumner 17:35 01 Jun 2008

...for trying - changed it to PPPoA and resent and retried, but still the same staus: no connection, and if i open IE and try to get bbc.co.uk - no internet connection.

I am now on my laptop using the old Sagem modem so a bit of time swapping back and to , to check the forum!

Interestingly, when i am on the PC and the new Belkin connected, i can access and connect to the network on my IPhone, but cant use the connection. Just connects but has no functionality - not sure if that helps to identify the problem and further?

  Stuartli 17:39 01 Jun 2008

Have you read Tiscali's Help pages?

click here

  RichieSumner 17:40 01 Jun 2008

I took a similar screenshot but hard to share it, not sure how!

Yes, the Belkin ADSL Status reads 'connected', although the internet status top right shows No Connection in red.

I note that in your screenshot, there are more 'fields' of data in the bottom left. Mine doesnt show WAN IP, Subnet Mask, and the final 3 - can't read clearly. Mine just has, in this order:

ADSL Status - connected
Data range - 2272kb/288kb
WAN MAC address - 00 17 3F 09 68 12
Connection Type - PPPoA (now!)

Still no luck though....

  RichieSumner 17:48 01 Jun 2008

I have looked but it doesn't help. The error 678 advice is basically check settings (done) and re-install drivers.

This is an intersting point though, as i UNINSTALLED all Sagem (old) drivers at the outset.

Then I link up the new Belkin, go to 192.x.x.x and add the details for internet WAN. Now I am trying to get online - but I have not re-installed any drivers. Is this necessary, or am I missing an obvious step somewhere?

Many thanks for your help.

  brundle 17:48 01 Jun 2008

Visit Stuartli's link, Tiscali have excellent help pages.

Ignore the computer and what networks it can and can't access, you have two distinct separate things to troubleshoot- the router>internet/ADSL and your computer(s)>router, the latter is basically working (though there may still be a few tweaks to apply to ensure the computer doesn't try to access the internet using the configuration it had when the modem was installed).

If the router hasn't got itself an internet connection no amount of fiddling with the computers will get you online.

Double check your user name and password.

  brundle 17:48 01 Jun 2008

No need for drivers with a router.

  RichieSumner 17:55 01 Jun 2008

...thanks first.

I'm with you that the issue is the router/internet connection.

As no drivers, I am doing the right thing ignoring the old Sagem and old Tisclai CD that came with it.

Presume I do not need to set up a 'network connection'? At present, under network connections, i only have one LAN icon that shows connected.

I'm in the process of trying the command netsh interface ip reset log.txt and then will report back.

Odd that i dont need drivers, but Tiscali help recommends uninstalling them, and then reinstalling them?

  brundle 17:58 01 Jun 2008

No, no need to set up a network connection, although sometimes going into the `Setup an Internet Connection wizard` can help to force the computer to access the internet via a router and not the old setup.

Again, netsh interface ip is for tcp/ip on your PC, the problem is the router at the moment. If you can connect to the configuration interface using a browser, TCP/IP is unlikely to be a problem.

You don't need drivers for a router (except network interface drivers), perhaps they're talking about USB modems.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017