Unusual Mandrake/driva Linux behaviour...

  ddd3 21:05 28 Jul 2005

I was having problems with my computer which I eventually ran down to a couple of blown capacitors. I was about to replace them when my sister pointed out that it would probably be easier and cheaper to go on to ebay and buy a dupicate motherboard. It sounded like a good idea so on I went. I couldn't find exactly the same board, but I did find a slightly more recent version of the same board, so I wanged it in and fired up, but the previous problems (Which I'd initially tried to cure by reloading Linux. Unsuccessfully...) meant that I got a kernel panic warning so I figured, just to make sure I took advantage of the new features my motherboard was certain to have, I'd load up Mandriva 2005...

I had no problems with loading, and it ran perfectly except for one tiny little problem. Not only wouldn't it connect to the internet, it didn't even detect my Speedtouch modem. So I tried to install it manually once I'd found Mandrake/riva Control Centre, which was no longer called that. I told the control centre to go and look for it and it came up with the modem and the onboard ethernet. I told it to configure the modem and it gave me a list of connection options, and this time there was a problem because the Speedtouch modem had always been on the list of options on previous versions. I tried PPPoA because that was highlighted. No luck. The 'Help' button recommended PPPoE so I tried that. Still no dice. So I tried all the alternatives. Nothing.

So I 'phoned my ISP and asked him to check the modem and line in case I'd damaged them while I was installing the new motherboard. The check revealed that the modem didn't appear to be connected to the computer, so I shuffled the USBs around a bit all to no avail.

So I pulled out my boxed set of Mandrake 9.0 discs, because I knew that had worked previously, and the boxed set had the microcode that you have to install from the Alcatel site with the download versions. Once again it installed without any problems, but now the modem worked fine. Great... except now I seemed to have lost half my apps. KMail was missing, Xmms was the only media player, Real was the only video player. What's more I was getting no sound anyway.

So I figured I would now 'upgrade' to Mandrake 9.1, which I had always found to be the most stable version before. Everything started OK, until I Okayed the licence, when I got a screen I've never seen before asking me what drivers I wanted to use. The list was 60 drivers long, there's no way I could check them all by trial and error without endangering my brain, and none of them had names which suggested what they might be used for. Furthermore when I did try a stab at it I discovered that Mandrake wanted me to specify every driver for every bit of hardware on the machine. The mind boggles...

So... Can anyone tell me why the Speedtouch modem won't work with Mandriva, where all my apps went with Mandrake 9.0, and why v.9.1 is asking me all these silly questions when it's had no trouble auto detecting in the past?

  dth 10:26 01 Aug 2005

This is quite a good howto for the modem:-

click here

Although why don't you get a proper ADSL/Router modem rather than use the USB one?

Sounds like your install has not completed fully - unless you've only completed a partial install. But without kmail is pretty partial.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?