unable to take ownership of my drive!please help?

  cmim 13:31 01 Jun 2008

hi folks,
a few days ago my external hardrive wouldent let me in and showed this message=
I:/rome is not accesible, access is denied
Its a maxtor 500gb external HDD and im running xp.

So i was advised this was a case of having to take ownership of he drive.so i did the below

1.restarted in safe mood
2.logged on(tried my log on and the administrator thts only apeared since safe mode)
3.right clicked on drive
4.properties,security tab,

then problems start=
theres 5 group user names=
administrators, creator owner, everyone, system, users.so wheni try to change any of the groups permissions this message apears=

Unable to save permisson changes on local disk. the file or directory is corrpted and unreadable.

5.now if i go to advanced, owner tab=
a=if i tick the replace owner on sub and objects box and apply or ok i get this message=

you dont have permission to read the conents of directory\device\harddiscvolumes\rome do yu want to replacedirectorry permissions granting you full controll.all permissions will be replaces if you press yes.

pressed yes and another mesage apears=
an error has occured applying security info to \devicedevice\harddiscvolumes3\rome
access is denied

b=if i dont click the replace owner on subs and objects box and appy and ok i get this message=
unable to set new owner on local disc(I) the file directory s corrupted and unreadable.

ok im really sorry iv wrote such a massvae message but i thought if i write it all down it might be easier to help, im stuck and extremely frustrated about this.I have gigs of family photos,movies adn allot of univesity work on this drive.

please help.

  rawprawn 16:38 01 Jun 2008

What make is your computer? Are you using Norton?
I fixed an Acer the other day which had loaded Norton 2008, and and couldn't get into the CD/DVD Drive. It turned out Norton was conflicting with Acer Security.

  rawprawn 16:40 01 Jun 2008

Try your External drive on another computer, it'spossible the drive has died.

  cmim 18:59 01 Jun 2008

the drives 2 weeks old, tried mit on another and it just does the same.Yeah im using norton 2008 and its a packard bell computer.

  rawprawn 09:58 03 Jun 2008

Have a word with Maxtor, it may need replacing.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017