Unable to set default ISP

  griffon56 13:24 18 Jul 2011

Running Win 7 Home Premium on Packard Bell iMedia desktop and using Firefox 5 as default browser, I can't set talktalk.co.uk as my ISP. I type it into the right box in the Internet Properties dialogue box, click 'Apply' and OK, but the next time I open Firefox it goes to 'about:blank' and shows a typical 'google' search page. The default ISP in The Internet Properties box is shown as 'about:blank' and talktalk.co.uk has disappeared. Anybody any idea what's going on?

  gengiscant 13:34 18 Jul 2011

Do you mean home page, as ISP is 'internet service provider'. Anyway I have just had a look at Firefox and what you need to do is open Firefox, browse to the page you want as your homepage, then click on'tools' then 'options' then 'general' then underneath where it says 'show my home page' click on 'use current pages' then click on 'ok'. That should be it sorted.

  griffon56 15:18 18 Jul 2011

Thanks gengiscant. By luck I found the same answer on Mozilla.com in an article about Firefox. My version of Win 7 doesn't have Tools - Options up above but if you click on the Firefox name it gives you the same choice. Why do they have to bxxxxr around with time proven layouts when there has been no actual change to them AND why is so much of the really important Windows stuff hidden down obscure paths which are not intuitive to find? Thanks again.

  tullie 16:00 18 Jul 2011

Its nothing to do with your version of windows,its an option in your browser.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

See the Best Button Badge Designs of 2017

iPhone X review

Black Friday 2017 : date, sites participants & bonnes affaires