Unable to power up laptop

  AroundAgain 01:08 21 Nov 2009
Locked

Hi
I have an e-System 3086 laptop which, possibly through damage as the hinge casing is broken, won't power up at all - not even a flicker!

It seems the charger unit is ok but that the power component in the casing is damaged.

Does anyone know if/how this can be repaired or does it mean the laptop is totally defunct and irrepairable?

Just seems a shame if it has to be scrapped/used for spares perhaps.

Cheers
Julie

  Strawballs 04:36 21 Nov 2009

If the small pin that the plug goes onto is damaged it means a new motherboard as it connects directly to it.

  AroundAgain 09:56 21 Nov 2009

Hi
The socket to plug into looks fine, from the outside, anyway. The power plug fits in well, so no obvious damage from outsite. I can plug it in etc, but just won't shown any signs of power getting through. Battery obviouly not been able to charge since this damage, as totally flat.

The casing over the hinge next to it is broken, though, indicating somo sort of impact at some time (don't remember being that careless with it)

So, I'm just hoping that a wire has become disconnected but don't know how to get into it to check!!!

Suggestions still welcome ...

thanks, folks
Julie

  Fruit Bat /\0/\ 10:21 21 Nov 2009

The DC jack sockettend to be soldered direct to the board.

Scenarios -
1. the jack socket is loose on the board and can be resoldered / replaced.
2. the machine has a seperate power board that can be replaced.
3. the socket is on the motherboard and the board is damage (probably not worth the cost of repair)

Stripping a laptop is not for the "faint hearted" and can be time conumming, this is why the cost of laptop repairs is so high (labour charges).

It may be worth getting a quote as to the cost of reapir.

click here are a recommended company for good reliable service.

  Fruit Bat /\0/\ 10:25 21 Nov 2009

HAve you tied running of the mains with the battery removed?

  AroundAgain 10:53 21 Nov 2009

Thanks guys

Just tried running off mains, with battery pack removed but still no signs of life anywhere. The plug felt as it if was firmly in place.

So, think my options would seem to be stripping it down myself. I did have a try but seem to remember I couldn't get into the bit where the power comes in. I shall investigate (carefully) again!!!

I do have a little soldering iron so, maybe ... ;)

I'll post when I've had a chance to do this. If you don't hear again ... ??? ;)

Julie

  Fruit Bat /\0/\ 10:57 21 Nov 2009

Good Luck. :0)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?