UNABLE TO OPEN UP SHARED FILES

  SECTION31 12:53 05 May 2009
Locked

Hello guys!

I have just bought a new computer for my daughter. I now have two Vista computers connecting wirelessly to the latest BT Home hub, (the black one). The older computer has Vista Ultimate and can see both computers on the network and access the public folders of the new computer.

The newer computer has Vista Home Premium installed and can also see both computers on the networks but is the problem – the newer computer can’t see the shared folders or public folders on the older computer. If I click on the icon of the older computer the screen just hangs for a while until a message appears saying “windows cannot access \\SEAHAWK”. If I then diagnose the problem a message appears saying that “windows found a problem that cannot be repaired automatically”.

Both computers have McAfee installed as supplied by BT and both computers have each other’s IP address listed as a trusted computer.

Any ideas?

  ashtonj64 08:10 06 May 2009

Hi I feel Just sharing the folder isn't enough especially in Vista, make sure you set the permissions to FULL access so that you can read/write and move/remove files.
Also, Kill the firewall just to see.
Just try the above said things...

Ashton

  dawood 15:59 06 May 2009

Make sure there is no firewall blocking on computer. Also have a look on the password protected file sharing click here and public folder sharing in Vista click here article to see any wrong or missing configuration.

  SECTION31 19:47 06 May 2009

Thanks guys. It looks like the problem is a firewall one.

If I switch off the firewall on both computers both computers can view each other’s shared files. If both firewalls are on then only one of the computers can see the others shared files. This would lead you to think that there is a difference in the settings on one of the firewalls – but I’m blowed if I can see any difference! Both firewalls seem to have exactly the same settings so why is one of them blocking the other computer!! Very frustrating. I’m not a complete beginner when it comes to computers but this is driving me nuts!

Any more ideas?

Colin

  mgmcc 20:20 06 May 2009

>>> Both firewalls seem to have exactly the same
>>> settings so why is one of them blocking the >>> other computer!

When you say "exactly the same", presumably you haven't allowed the *SAME* IP address in the 'trusted' section of both firewalls, i.e. the IP address of only one PC?

I always recommend allowing the entire Subnet, rather than individual IP addresses so that if, for any reason, a computer is allocated a different IP address, this doesn't cause a problem. I don't use McAfee, but seem to recall that this is done using the 'broadcast" address of the Subnet, which is 192.168.x.255 (where the third octet "x" matches that of the router's IP address).

  SECTION31 06:50 07 May 2009

I do have the entire subnet allowed rather than individual IP addresses. The "trusted" range is listed as 192.168.1.0 to 192.168.1.255 in both firewalls.

  mgmcc 08:44 07 May 2009

>>> The "trusted" range is listed as 192.168.1.0
>>> to 192.168.1.255 in both firewalls.

The range of *USABLE* IP addresses is 192.168.1.1 to 192.168.1.254

192.168.1.0 is the actual "Subnet" address (i.e. it is all addresses from 192.168.1.1 to 192.168.1.254)

192.168.1.255 is the "Broadcast" addresses, used to send data to all computers in the Subnet.

I think you've already established that it is a Firewall issue. On the one occasion that I have configured McAfee for someone, I know there was a setting somewhere to allow access to the entire Subnet and it was done by entering the "Broadcast" address and only that address, i.e. 192.168.1.255

  SECTION31 17:27 08 May 2009

Thanks for the info. What I can't work out is why both computers are not acting the same. I could understand it if both were denying access to each other but the problem is only one way despite both sets of settings being the same. I must be missing a trick here.

Not sure what else to try.

Any other ideas?

  SECTION31 19:49 12 May 2009

Ok, sorted!

I needed to go in to event logs in McAfee and mark as trusted one of the attempts from the other computer to access the public files. Once this was done the two computers began merrily started sharing files.

Still not sure why one computer would do this without the trusted prompt and one would not but hey, who cares as long as it works :-)

Thanks for all your help guys.

Colin

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone