Unable to log on to Remote network Active X issue?

  Jungle 13:03 09 Feb 2009
Locked

Hi I wonder if someone can help.. Apologies but I typed this out a second ago and lost it, so it might be a bit shorter !

Basically I cannot access my work network, when I start I get so far then it logs me out. It used to work several months ago before I completed some updates and ran a registry cleaner.

1) My initial thoughts were that it was the registry cleaner being too aggresive however I do not get any DLL errors ?

2) My next thought was that it might be firewall related as I get so far then it just boots me out, but I have tried turning them off and it makes no difference.

3) My next thought was that it related to the Windows Updates, and tried to re install the Windows Installer and backup the DLLCACHE, then reinstall JAVA. But this didnt work.

This was the fix

click Start, and then click Run
in the Open box, type cmd, and then click OK
at the command prompt type:
attrib -r -s -h "%Windir%\system32\dllcache"
this remove the Read Only, System and Hidden flags
At the command prompt, change directory by typing:
cd %WINDIR%\system32\dllcache
now type the following lines, pressing ENTER after each line:
ren msi.dll msi.old
ren msiexec.exe msiexec.old
ren msihnd.dll msihnd.old
this renames and thus disables the Installer Service backup files
Shutdown and restart your PC
update the Windows Installer files to the click here

4) My next thought is maybe its something related to Active X, as it pops up at the top but dissapears before I can install it. How do I correct this ?

5)My final thought is it might be an IE issue, but I dont know where to start.

Does anyone have any thoughts??

Thanks
Jungle

  Jungle 19:34 09 Feb 2009

Bounce

  brundle 20:46 09 Feb 2009

The only one of those that makes sense to me is the firewall, none of the others are directly related to remote network connections. A lack of DLL errors after registry cleaning is no indication that everything is working the way it was before.

How are you accessing the network - VPN? If not, please elucidate and give more information about your setup - XP I assume, default browser, third-party or built-in firewal, ISP etc

  Jungle 11:51 10 Feb 2009

Hi Brundle thankyou for your response.

Yes it is Windows XP machine, the Browser is Internet Explorer 7. The Firewall is the standard Microsoft Windows Firewall + Third party firewall (PC Tools) on one machine and ( AVG Internet security ) on the other.

Access is via a VPN, basically I enter a website, key in a password which links me to the work system. At that point I then need to install Active X and Java to bring up my work desk top profile so that I can access Outlook and work internal systems. ( It doesnt get this far, and this is when it boots me out)

Both machines used to be fine before Xmas, but now will not access the work network, just get so far then get logged out when you need to install Active X and Java.

I have checked the password and access on another XP machine and access was granted with no problems.


Thanks
Regds
Jungle

  brundle 13:40 10 Feb 2009

Microsoft Windows Firewall + Third party firewall (PC Tools) - one or the other, not both at the same time.

OK, I see what made you try the steps you outlined now.

Are you using a router or usb modem? Is port-forwarding enabled if you're using a router? Was the other machine you tried connected to the same device, on the same broadband connection?

click here

  Jungle 14:45 10 Feb 2009

Yes the home PCs are connected using a router. I will need to check if port fowarding is enabled, although Im not sure this is the issue. Ill check out your link.

The test machine that worked was on a completely different network over at a friends house. The test machine was running through a router, Ill need to check port forwarding but I do not think this was enabled on the test machine.

Ill have a dig around on the Firewall and Port forwarding areas to see if this changes anything.

Thanks for you time
Jungle

  Jungle 08:09 11 Feb 2009

Morning...

Last night I checked the router settings and could not find any probs.

1) As a second test to completely eliminate the router I disconnected it and used a USB modem supplied by the Broadband provider. At the same time I ensured no Software Firewalls were running. Basically the same thing happened it disconnects abruptly.

One thing that I did notice was that Active X was now installing and it failed when asked to insall " Junpier Network " it opened another IE tab and this just came up " Disconnected " instantly.

So I think the problem is related to Juniper Network and a registry file somewhere.. I have had a quick look at their knowledge base but didnt dig up anything meaningful. I will keep hunting.

Worst comes to the worst I will do a fresh reinstall of Windows XP as the computer doesnt have too much on it, that way any adhoc registry issues should be resolved.

Thanks for your assistance so far.

Regds
Jungle

  brundle 10:46 11 Feb 2009

Is it "Juniper Networks SSL-VPN Client ActiveX Control" ? Have you added the VPN network address to trusted zones in IE?

  brundle 10:47 11 Feb 2009

Can you connect to other secure sites successfully (not via VPN)?

  brundle 10:48 11 Feb 2009

If that is the ActiveX control you're referring to, look at the debug log mentioned in the docs; click here

  T0SH 11:24 11 Feb 2009

Why not use system restore to go back to before you broke it :¬)

after all that is what the safety net is provided for

Cheers HC

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017