Unable to connect laptop to home network!!!

  lavabubble 20:59 28 Dec 2005

Hi all

I have tonight bought a laptop and haven't been able to connect it to my home network, in fact I can't even see the details of my network on the available connections list!!

I have enable the SSID broadcast and even this hasn't worked. Accordingly, I am ready for slinging the lot in the bin - we all get there I suppose!!!

Any advice appreciated (my bro set up the network so I don't know all the relevant details about it). New laptop is a Acer Aspire 3613WLMi and router is a D-Link DSL-G604T. Both computers are running XP home.

Any advice gratefully appreciated

Kel x

  pauldonovan 22:10 28 Dec 2005

Do you know if he enabled mac address filtering on it? It sounds like this is an existing network that you had already? If so he may have limited the "mac addresses" that can connect.

If you know how to enable SID broadcast then you are part way there - can you see an option around there for mac address filtering? If so you need to add your mac address (of your laptop) to the list if this option is enabled.

Your bro may have secured it using a secure key in which case you'll really need to know that. Might sound daft and i'm sure you can't otherwise you wouldn't be here, but can't you speak to your bro?

  mgmcc 22:12 28 Dec 2005

Check in the router's wireless settings that you don't have MAC address filtering enabled. This is a filter that only allows network adapters whose MAC address (Media Access Control) has been entered to connect to the router.

The router *may* also have a setting to connect only to 802.11b adapters, only to 802.11g adapters or to both "b" and "g", so check that is correctly set for the adapters you are connecting with.

  lavabubble 22:56 28 Dec 2005

Hi guys and thanks for that!

The MAC control was enabled so I added the addy of the laptop and it can now see the network. However it is stating that it is "limited or no connectivity as the network did not assign an address to the computer"

I am guessing that this is something criminally simple to sort out, but my novice status means I haven't the foggiest where to start with that one! Can I call upon you kind and good natured folks again for some more advice??

p.s. Paul, I would normally call my bro to sort it out but he was taken ill on Christmas Day and isn't better yet so I thought I would try and sort it myself (which I couldn't lol). I really really appreciate all the help you have both given me so far!

Thanks again

Kel x

  mgmcc 23:18 28 Dec 2005

Now that you can see the wireless network, have you actually "connected" to it? Once connected the little icon should get its "halo" to show that it has connected to that network.

At the moment, you have "Limited or No Connectivity" because the adapter has been unable to get its IP address from the router. Windows has almost certainly allocated a 169.254.x.x address with which you won't be able to access the network/internet. This should update automatically once it can access the router to get a correct address, which it should do when you have "connected" properly to the wireless network.

You could also try right clicking the Wireless Network Connection and selecting "Repair" which should force it to renew its IP address.

  lavabubble 23:30 28 Dec 2005

It has got the green (( ))'s round it (pardon the expression) and indeed, it has given it an IP as above. I have tried to repair it and this has not worked as it tried for several minutes to get an IP address but now states "automatic private address" and shows the 169.254 etc one.

  mgmcc 07:56 29 Dec 2005

I'm still not sure that you have actually "connected" to the wireless network, although you may have a good signal strength and the devices are communicating.

Wireless adapter software is all slightly different, but if you look at my Belkin software - click here - you will see the little icon beside my network name, Maxigroup, has its "halo", a circle around the top. That would be missing if I wasn't "connected".

  mgmcc 08:00 29 Dec 2005

Pic of icon without its "halo" - click here

  borolee 11:01 29 Dec 2005

Hi folks. I am also using Belkin. My 1st laptop is connected directly too the router, which is connected to my NTL box. The other computers in the house can connect to the net ok, but cannot share files. Please help!!!!!!!

  lavabubble 11:07 29 Dec 2005

Having checked that, there is a halo around the top of the icon, and this morning after rebooting both systems the laptop has its own IP addy etc and I can ping it from the PC the router is attached to so it all seems to be connected.

However I still cannot access the internet from the laptop. I have ensured that the login details are the same as the PC in case that made any difference. Is there anything you can suggest that could be the cause of this?

  mgmcc 12:07 29 Dec 2005

If the laptop has definitely got a correct IP address in the same range as both the other PC and the router, and can ping both the other PC and the router, I don't see why it shouldn't have internet access.

If you are using Internet Explorer, check in its "File" menu that you don't have "Work Offline" ticked. Have you tried to see if you can check email with Outlook Express?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?