Unable to connect to internet in Windows 7

  Fleetblue 11:52 07 Nov 2010
Locked

I’ll start from the beginning. I have two home PC’S. PCA runs Windows Vista and has a Broadband Cable Modem connection to the internet. PCB ran Windows XP and, having no modem, connected to the internet using an Autotec Cable/DSL Router from PCA.
I recently upgraded PCB to Windows 7 which necessitated a clean installation but now I have no Internet access on PCB.
What I have done.
Using ipconfig /all I checked for an IP address but PCB no longer appears to have one.
Ethernet Adapter Local Area Connection
Media State: Media Disconnected
Connection-Specific DNS Suffix: Blank
Description: Intel R> Pro 100 VE Network Connection
Physical Address: 00-13-20-30-6F-03
DHCP Enabled: Yes
Autoconfiguration Enabled: Yes
I tried to reconnect to Broadband using my original Username and password but received an Error 651 message.
Changed the raspppoe.sys file to raspppoe_orig.sys and downloaded and installed the Vista raspppoe.sys file. (I’m assuming I’ve done this correctly. Both the raspppoe_orig.sys and the new raspppoe.sys file are in the drivers folder). Still Error 651.
Could I have used the wrong Username and password? Would this have generated an Error 651?
Any help would be greatly appreciated.

  Fleetblue 13:31 07 Nov 2010

124 "rasppoe.sys" change came from a Windows 7 site.

Checked all my cables they are all plugged in and the internet was working perfectly on PCB until I installed Windows 7.

PCB is not connected directly to the router by cable but has an Actiontec 802UIG-1 connection. (sorry it's Actiontec not Autotec). Is this what you mean?

As far as Broadband goes when I select to connect using Broadband it asks for a username and password.

  Fleetblue 14:52 07 Nov 2010

Was showing as "Unknown Device" in Device Manager with ! sign. After downloading and installing the drivers (thanks for that) that has now gone. Now showing PCI Modem with ! sign.
Edit: the wireless device is now showing under Network Adapters as working properly but still no connection? Also showing there is WAN miniport PPPOE with ! sign.

  Fleetblue 14:58 07 Nov 2010

124. Internet now up and running. Many thamks for your help my friend.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?